Numeric keypad numbers 1-9 move head to X0, YO only

When attempting to use the numeric keypad to move laser head, I get only one laser head movement, it moves to X0, Y0 (front left corner) . This is the same for 1-4 and 6-9, numbers lock is on… Keypad will do nothing else. In Carbide Motion the keypad works only when numbers lock is off.
Also, if I turn jog on and restart LB the step movement doesn’t work properly, if I turn off jog but do not restart the step movement and jog work fine.

J-Tech laser on shapeoko 3 XXL.
GRBL 1.1 f
Crappy Lenovo Ideapad 110

I tried a Logitech keyboard and had the same results.
Thanks for any ideas. I’m probably missing something very simple.
Forgot to add running windows 10 all updates as far as I know.
Running latest LB.

Have you zero’d the machine to the front-left of the workspace?

Typically there’s a macro you set up that does the required workspace offset, $10 and $32 settings.

Yes, but I didn’t set $10 or $32 in the two macros. I also need to set “status: show buffer data $10” to be true in cnc mode and false in laser mode. Is there a way to set this in the macro? It is listed as $10 but doesn’t change when $10 is changed in the macro.

Minor issue to change, just need to make a note to remember to change when shifting between cnc and laser mode.
Thank you very much for the help, I should have seen the enable laser but did not. I didn’t know about the $10 either. An easy fix once you showed me the link.

Ok, all is working now except I am unable to adjust the z axis from the numeric keypad. I am guessing that is not available.

For those that are using Shapeoko 3 XXL with J-TECH laser here is what is working for me. I set up two macros as follows:


How long ago did you set up LightBurn? It should have offered the option to set those up for you when you first set up the machine, but this is a more recent addition to the software (probably within the last 6 months)

I set up lightburn a few months ago, but never looked into using the numeric keypad for movement. So it worked for what I was doing. I just upgraded my Shapeoko to an XXL. I’ve never used the cnc router, so I was trying to get both to function correctly.

The only issue now is that I cannot use the numeric keypad to move the z axis (as far as I know) . This is actually the main reason I want to use the keypad. I generally adjust the z position on each tile I engrave and it gets tedious.

I am looking for a wireless solution for the move functions (numeric keypad, keyboard or game controller).

Again thanks for you help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.