Objects open backwards and upside down after adding Fiber Device

I have a Ruida controler for my CO2. LB has worked awesome for that controller. I added Fiber (JCZFiber Device) to the same computer. My default device is the Ruida. Since I’ve added a fiber device to my windows based OS system, my saved fiber files will open upside down and backwards. I have to open up a blank file and then change to JCZFiber and then open file to ensure it doesn’t come in all wacked up. Any suggestions? Is it my settings or an anomoly within LB?

Both machines have different origins…

I have a device profile for each laser and with the fiber, for each additional lens.

This will carry the origin information with it… I’d suspect if you just select the right device the image would correct itself.?

I can load some artwork while a fiber device is selected and it will be oriented in some way other than right… once I select the Ruida, it’s corrected…

I set the default device to whatever I’m using at the time… I usually don’t switch back and forth too much…

Let us know if this isn’t working…

:smile_cat:

I too have device profile setting for each of my lens to include the C02. If I open a file with the appropriate fiber profile, it works as advertised. However, if I open file in Ruida profile first, then change to a fiber profile, throws the image off screen. It looks ok, except upside down. If I change the image in anyway for example just trying to center it. It changes the size and location of some of the inner graphics/letters. If I do a ctrl z it just makes it worse. Its very odd. Again, I cannot seem to find a common issue. I’ve tried it on a bunch of files and I got the same error.

Are you opening a file that is correct with the co2, then switching to the fiber and have this problem?

If this is the case, it’s to be expected…

Else, maybe we are not communicating…

:smile_cat:

You have summarized it perfectly. However, I think it makes since that the project would move positions based on the different device size(s). What I would not expect is for it to change its orientation and not have the ability to modify it (successfully) to its original orientation. If it was just simply an orientation problem and I could change it back; then fine. But not having the ability to resolve the orientation and it automatically making changes that I cannot revert backwards is not acceptable for a great application such as LightBurn. I’ll see if it will let me up load some pics so you can visualize what I’m saing.


Ruida Image as planned

but I see the issue now…


Would you mind posting the .lbrn2 file. It should, as you advise, change the whole image if all of this is in the project file. Usually it allows just a mirror flip or two to correct the entire image.

I’d like to try this myself… never have seen it only do part of the image.

Are you using version 1.3?

:smile_cat:

Any help is always welcome. I’m still trying to learn how to spell Fiber.

US Navy Retired circle slate.lbrn2 (325.4 KB)

1 Like

Sorry, Yes I’m using LightBurn 1.3.01.

Did you build 1/2 of this using the Ruida setting and the image part using the fiber?

Here I opened it with the Ruida, then changed machines to the fiber…

Ruida

Fiber

Both have one part of it reversed… doesn’t really look like yours either…

I get the same operation on both the release and beta version… I think it has to do with how you built the artwork…

Can you elaborate on that?

:smile_cat:

Change to the other galvo as the x axis. When mine is set as galvo1 to be the x axis it does this same thing. I changed to galvo2 to be x axis and it fixed my issue.

If you look at the artwork, part of the image or lettering is reversed… If you flip it, the reverse is corrected, but the correct part is now reversed…

:smile_cat:

@Rick and I are are looking at this file right now.

It’s in an unusual state and we need more info.

How did you generate this artwork?
In particular how did you generate the text and how did you curve it?

Do you have any donor files you began with or was this completely designed within LightBurn?

We are looking to reproduce the process here for a better understanding of what we are looking at.

It may have been a while, but as best you can recall; a step by step procedure would be most helpful. :slight_smile:

Jack and John; is there another way I can send you the step-by-step process I used to recreate this issue. I’ve captured it in Word, but this forum doesn’t allow Word. I have pictures and a step by step of how I created the issue going from Ruida to Fiber Device Profile and then recreating the issue by creating the file in a fiber device profile in it worked perfectly. Then I used that exact same file that just worked, opened it up as a ruida device, then changed it to a Fiber device profile and the same issues appear. Note all tests were created and revalidated on 1.3.0.1

You can save as RTF from word and then change that extension to TXT, which is an allowed format for posting. :slight_smile:

prob. will lose the pics.

Those you can add in the forum post directly using the upload button, or just drag and drop the image into the forum editor.

Hope this gets to ya.

Test case for LightBurn Robert Hodge 27 April 23 RTF.txt (3.4 MB)

Here is the process I used to the best of my knowledge:
• All processes were native to LightBurn.
• Opened LB, native profile is a Ruida Device.
• Used a silhouette image of an eagle and flag and traced.
• Created Circles
• Used Boolean Assist for the eagle/flag with circle (Intersection A to B).
• Duplicated Circle a couple of times
• I then offset out by .001 to create a larger black circle.
• I didn’t take too the time to figure out how to create multiple versus and place on a circle (one on top and one on bottom). So, I typed out words and used the Blue Dot to curve verbiage until I got what I wanted. I used rotate, moved text handles in/out, used the Shift, Ctrl and Alt to move object in very small increments. That option doesn’t work if I try to move left, it always brings up Notepad App.
• Then I created more circles with offset (in, out and both) to get it to the desired image you’ve seen.
• Inserted Text “2023” and placed between flag stripes
• I used an older Ruida file and copied in the stars.
• I then used the Circle array tool for the star pattern.
• Grouped all patterns.
• Changed size to 3.5”
• Saved

Note this isn’t the only file this happens too. I have several others that I’ve created in ruida device profile, and I believe I’ve tried using a file that I created in a Fiber Profile and went back and forth between CO2 and Fiber and had similar issues.

Changed device profile to Fiber
• I opened my 112 Lens profile and the image shot way off the grid upside down.

Figure 1 View of Image after changing to Fiber Profile
• If I use the rotate handle and rotate it 180 degrees; the image and 2023 text are fine. However, the words in the circle are backwards.
Figure 1 View of Image after changing to Fiber Profile

Figure 2 View after changing to Fiber
Figure 2 View after changing to Fiber

Figure 3 Text in circle dropped in size
Figure 3 Text in circle dropped in size

Figure 4 View after rotating 180 Degrees
• If I ungroup the image and then try and change the words as they should be, the top & bottom verbiage changes its size and crown up or down orientation. Meaning the top verbiage would fit perfectly if that were the verbiage to be placed on the bottom and vice versa for the bottom verbiage would be perfect for the top.
Figure 4 View after rotating 180 Degrees

Figure 5 If I ungroup and try to flip verbiage
image

If I ungroup everything in the image and rotate and orient as it should look, nothing happens to the image (meaning it looks perfect), until I hit group. Once I hit group, it acts like the other stuff I identified above.

• If I open LightBurn (no file selected, blank page),
o then change to Fiber Device Profile,
o then open up file; it works 100% correct.

Fiber Profile creation and open/use in Ruida Device Profile.
• If I create a project in a Fiber Profile save it and then reopen it in a new session, I have zero issues with any tools, orientation, movement: saving, etc….
If I use that exact same file listed above, then open it as a ruida profile (my default profile) and then change it to a fiber device profile; the exact same issues happen as I’ve stated above.

I have edited to now show these steps here on the forum. Helpful so others can review and offer workflow suggestions. I did not recover the images from your file, so if you post them in another entry and can edit to bring these in as well. Please name image files to match where you have tagged in your text flow. Example, ‘Figure 5.jpg’ (or whatever the image format). :slight_smile:

Thank you

1 Like

I am having the same exact problem as Robert, but ONLY after adding my Haotian 60w MOPA to LightBurn. It never happened when I had just the Ruida profile for my CO2. It is beyond frustrating since I switch back and forth between machines often. I can create a file with many elements in the default Ruida profile for my CO2, save the file, close LB, reopen LB and load the file just created, and the images are reversed, the text is reversed, flipped horizontally and vertically, the text curve is flipped in the opposite direction, etc. I love LB, but this is GREATLY slowing down my work. I ask for help from the experts. Thank you.

There is a subtle difference between open and import and I want to confirm that this isn’t the cause.

When you reopen LightBurn at Step 4, is LightBurn in the Ruida profile again?

When you load the file in Step 5, do you:
Click File then click Open or…
Click File then click Import or…
Drag and drop the file into LightBurn?

Do you change the device profile from Ruida to Galvo at any point in between Step 4 and Step 6?

Are you using two different computers?

I only ask about the different computers because not having the font loaded on the computer seemed to be responsible for one of the odd text behaviors. With the Font loaded, several testers here confirmed the file rendered properly.