OBS camera not recognized in Lightburn v2.1.01

With older versions of Lightburn, I could use a wifi camera in combination with OBS virtual camera. When I upgrade to Lightburn V2.1.01, I can no longer select my OBS virtual camera. The same goes for other virtual cameras.

Is this is choice or a bug? Because I’m stuck with an old version of Lightburn now while I would really like to upgrade.

1 Like

Still hoping for a reply from someone. I can’t be the only one using OBS because I’ve seen it mentioned before.

Due to the inherent complexities in cameras that function on computers, there are some caveats to how LightBurn interacts with cameras. Only “UVC” cameras are supported, meaning most phone cameras, IP cameras, and “software” or virtual cameras, do not function either partially or wholly.

This isn’t an intentional or overt design choice, but a limitation of the current approach to how LightBurn handles cameras for maximal reliability across all of our users.

You may have some luck looking for a plugin that provides this functionality within OBS, but I do not have any recommendations at this time. If you use the search tool on the forum you can find some other threads that may be helpful, like this one: Wifi camera shows up on OBS app but when I select it in Lightburn, its just a blank rectangle - #14 by Hye_Maker

Thanks for your reply and the explanation. The thing is, the OBS camera worked perfectly fine up until V2.1.01. I could select it as a camera and it just worked. In the latest version, the OBS camera option is just gone all of the sudden, I can only select my Facetime camera. So I don’t understand what suddenly changed. Using USB camera isn’t an option for me because the laser is in another room. :frowning: