Odd electical problem with used Laser

Hey All!

Long story short - I purchased a new (but faulty) Chinese laser (black and red, the large one) at a bargain price. The original owner was having no luck with it it was tripping his electrics and causing all kinds of issues. By his own admission, he wasn’t exactly keen to play with the electrics and he wanted rid

It is quite literally new. But being a Chinese laser expecting any level of customer care is pointless…so here I am! :stuck_out_tongue:

Upon starting it up it was clear there were some issues - after a good few hours of swapping bits around, and actually taking my Ruida controller from my other laser and fitting it the problems persisted. In the end, I settled on the PSU being faulty and swapped it out. Upon doing so everything was fine. I had my laptop (not powered into the mains) running it just fine, it was working exactly as expected, flawlessly infact

And then it all went a bit wrong. I spent the next hour moving the garage around, making space for it, getting the air/water sorted. Turned it on again and still all good, everything running as expected.

I then plugged in the USB (from my main wired into the electrics) main PC and the electrics tripped. At 1st I was unsure what caused it, so I unplugged things, changed sockets (the usual) but after a while, I noticed it was the USB leading to my computer. When it was unplugged it was fine, when plugged in the garage would trip, I also tried an alternative usb but still had the same issues.

There is one other thing I’ve noticed - the laser runs from a standard kettle lead - all of my standard British plug kettle leads won’t power the laser, only the kettle lead (with a two-prong plug and UK adapter) run it.

I’m wondering if there’s a voltage mismatch or something.

Anyway, at this point, I’m looking for advice and recommendations. I think in the process I killed my main pc (it was cheap, not the end of the world) , so not all that happy to plug my laptop into it, thats not so cheap!

I’m wondering if there’s potentially a ground fault on the machine which caused the original power supply to go bad and causing the new symptoms.

Your cheap laser seems to be getting expensive.

1 Like

Lol, tell me about it. Thankfully I could kill around 10 cheap pcs and I’d still be In a good place with the laser. That said, I don’t want to kill anymore computers looking for the fault!

Certainly a trade I would have made myself.

It’s almost certainly not a voltage difference issue otherwise you’d have more fireworks. Check if there’s a voltage switch on the power supply and make sure it’s set to 220V.

Also, I’m assuming that your UK adapter is just a dumb shape adapter and not converting voltage. That’s what makes me think this is some sort of ground fault since it’s not working with a 3-prong plug.

The fact that your computer got shorted through USB is also an indicator.

I’ve heard that the ground wire on some of these units are only connected to paint and don’t get a good connection to bare metal on the chassis.

A quick search brings up this site:
How To Connect Ground Wire Of Laser Equipment | Mactron Tech (mactron-tech.com)

1 Like

It’s grounding through the USB ground, as a guess.

I had a similar incident with another Chinese power supply.

So something is not correct and a good reason to use the Lightbrun Pi bridge…

In my situation it was the supply that was ‘cheap’ and had a floating ground…

Check the chassis of your machine to your home ground and see if you get voltage. In the end that’s how I isolated it, but had to remove it to be sure.

I would have thought that the machine would have a good ground to your mains or home, so it sounds puzzling.

Good luck and don’t get ‘lit up’ :crazy_face:


1 Like

Update - and still no luck

Today I have tried the following

Unplugged everything from the 24V PSU and wired it directly to the mains (using kettle lead/uk plug 3 wires) and that started up fine

unplugged all peripherals from the controller and that powered up fine - I’m 99.9999% sure the controller is fine as I originally (as a test) removed the controller from my other laser and installed that as a test - the issues persisted.

As a reminder, I’m also using a new Laser PSU here and that has not solved the issue - so like the controller, I’m 99.9999% sure the issue is not with the PSU

But I do now believe the issue is on the wiring/electrics on the Laser PSU side.

(see image) when I disconnected this block, the machine starts up just fine - no grounding issues. But obviously, I cant fire the laser. I’ve checked the wiring to and from this block/to the controller and it looks to be correct

I’ve inspected the wires to and from the laser/psu itself and they look good, clean and uninterrupted.

Another reminder - the machine and laser will power on just fine IF I used the two-pronged (non grounded) plug. So like like the PSU/Controler this tells me the laser is capable of running

Anyone have any thoughts!?

I think what’s happening is the one of the supplies have a ‘ground’ this really isn’t in our terminology.

I think your instincts are correct with the issue not being the lps.

It has to be one of the components that go to the ‘mains’, like a power supply. No other component has the ability to do this.

The lps wiring is clear enough I can see that it looks properly attached… The great photos you took made that easy, thanks…

If it ‘runs’ with an UN-grounded plug, you could measure the ‘potential’ difference between the mains ground and the machine ground. If it’s full mains voltage or if it’s a ‘partial’ voltage. That may be a clue.

You may have to disconnect supply by supply till you locate the issue.

It dawned on me another similar issue I saw and I’m starting to wonder if they have something in the basic wiring of the mains ‘crossed’ up…

What I can’t see, but I think you’ve confirmed as correct, but I wonder, is how the mains are wired within the cabinet.

Is something ‘floating’, ‘crossed’…?

On my machine, both ‘mains’ are switched by a dpst on the machines outside panel. In effect removing the mains when the switch is off. Usually one side of the mains have a ‘hot’ side and one at ground potential… The only wire connection when switched off is the ground from the mains to the cabinet.

I learned very well not to trust these ‘Chinese’ power supplies. I always put them on the bench and check them before I install them. Especially to how it’s grounded…

Good luck


1 Like

My next plan I think will be to disconnect the laser and attach it to an old 40w laser I have hanging around, if that still faults my next option will be to unplug everything and re-wire again only the bare minimum and do so via a direct connection to a 3 pin plug, circumnavigating the plugs and switches at the front of the machine.

If it ‘runs’ with an UN-grounded plug, you could measure the ‘potential’ difference between the mains ground and the machine ground. If it’s full mains voltage or if it’s a ‘partial’ voltage. That may be a clue.

Out of curiosity, how might I do that?

cheers for you help btw!

If it’s working without the ground, use an extension cord or something and measure the voltage between the machine and the ground pin of the cord. In the US it’s the big bottom one…

But I’d guess if there is a problem you’d read voltage to the plumbing, most of that stuff has common grounds… that’s if you don’t know how to get a hold of a ground.

I would have thought you would have ‘felt’ the voltage, if your get grounded and you touched the cabinet…

Of course we’re making a couple of assumptions one of which it’s a grounding problem…

IMHO, after being in mine and seeing the stuff they did, they ‘broke’ it at the factory when it was wired…


1 Like

Random thought…

When I unplugged everything but the essentials I kept all the components connected to the ground bolt on the case. This inc component that I disconnected from the controller/power etc

Could it be possible that this would be an issue two - I obviously disconnected the components, but I didn’t disconnect their ground to the machine. Might this have caused an issue when I plugged it all in thinking components are totally disconnected but are in fact still connected via this cable?

Hope that makes sense

It depends on what ‘disconnected’ means to what you are doing.

If the mains are removed and those go to the component is shouldn’t matter. However is the hot side ended up crossed to a device during the assembly in China, then it could be an issue.

I actually saw this a year ago or so…

If you ‘ohm’ out the ‘hot’ side of the plug to ground, do you get anything?


Ive disconnected everything, my current setup looks like this.

Motors, lights, pointer, usb etc all disconnected from the mains and from the controller.

And still, it’s tripping the electrics


Is this ‘popping’ a gfi or a circuit breaker from over current? Might help if we knew, probably impossible to tell if it’s a gfi.

If there are no components connected, it would seem to indicate it’s how the mains are wired through the machine.

Did you ‘ohm’ out the power plug to see if both sides had conductivity to the ground pin? I would expect the common to be…but…

Try an ohm meter to check it out (no power of course)… if it shows up this way, it might be an easy fix.

The common goes all over the machine on mine, so it could be anywhere along the lines.

Expecting a new air compressor (a quiet one) to show this morning… so I’m sitting here waiting…


I used a multimeter on the ground pin of the plug with the internal ground wires/connections on the Psu and it all confirmed it connected (reading 0 or very close to 0). I’m not exactly an expert when it comes to multimeters minds.

one thing I’ve not checked is the 24v psu - I’m assuming its set to the correct voltage, simply because Id have thought nothing would work (ground or no ground) is it wasn’t?

Let me take a couple and clarify the mains power…

Screenshot from 2022-03-14 10-36-52

Many plugs are ‘polarized’ with the large/small ‘blade’ height. With no ‘third’ wire (ground pin) you could flip the plug over.

Notice that the ground pin, in green, goes to the equipment ground. There is the ‘system’ ground, commonly referred to as the ‘neutral’. Which is the return path for either each leg of the mains.

System and equipment grounds are usually tied together in the electrical breaker box where power comes into your home. So in effect you would probably get continuity between W and G.

What I was suggesting is use the ohm meter to see if there is continuity from X on the plug to G on the plug… No power applied, just a check to see if it’s crossed somewhere… With everything disconnected it show an ‘open’ circuit or no continuity.

These are all checked from the machine, not the outlet as the drawing is showing, but the same rules apply…

I use ohm meter to check if things are connected, and volt meter to check actual operating voltages.

You would probably get full ‘voltage’ if you check from X to either W or G…

Make sense?

It would be worth while for you to use them. They are low cost and can point you to the issue quick. Yesterday my fan didn’t start… two seconds with the voltmeter, loose screw on the ss relay…

Good luck


Cheers for helping me out jack.

So, I’ve checked for continuity on the ground pin across multiple other wires and also the other two pins (as in X and W) and all I get continuity from is the other ground wires

But…Im also getting continuity with the ground from the negative wire of the laser tube?!

I assume I’m doing it correctly.

Let me see how mine reads… I’ve been in there but it’s pretty much factory…

Although not required, I would think that ‘Equipment’ Ground (G) should be the same as ‘System’ Ground (W)… Apparently they do conflict…

Since it runs when ‘un grounded’, we have to assume it’s ‘loop’ or problem is via the ground connection.

I’ll have to percolate on this a while…


Hey Jack,

Little heads up - I got it working! Turns out the 24v PSU was the issue. Ordered a new one and it all working! :slight_smile: #