Odd problem with latest version

I have an Atomstack x7 pro and am experiencing an odd issue with the latest update of Lightburn.
The problem is When I am burning a project with Lightburn and want to go to Google to search or look up something while the project is burning, My laser will start to jidder along the x-axis.
Once I pull away from Google, I go back to the main screen of Lightburn and go back to normal speed.
Back to Google screen and again laser starts juddering.
Switch back to Lightburn and everything runs as normal.
I have tried a different computer and a laptop with the same results.
Is anyone else experiencing this?
Does anyone have a suggestion?
Everything seems to point to Lightburn software.

Any help would be appreciated.

Hi David.

Please share a few screenshots, specially froM EDIT > Device settings
And a screenshot of your latest design you noticed that happening showing the laser and layers panel.

Do you use Chrome browser? Can you try another one? One thing that came to my mind is that some browsers can be used to program microcontrollers and therefore try to access serial ports. That’s very unlikely, but the only thing I can imagine right now.

Thanks for the input, i use win 11 and will try another browser. Not bad idea. I report back with my findingd.

Hopes this helps, Also have try various web browsers with same results.

Maybe open task manager and check the performance tab, it system load goes up once you switch to the browser.

Will try that thanks, try different browser with same result also. This is definitely odd that it affecting thr serial port like that. Thing is i try it on a laptop and desktop with same results. Driving me nuts trying to figure it out.

Also check if Anti-Virus and/or system updates kicks in.
Also try with browsers open but Network disabled.