Offset fill still acting up

xTool D1 10W laser.
I have posted about this issue but the topic has since been closed.

Whenever using offset fill on a circle I can see the laser slow down and dim at the same point on the circle, every time around. It doesn’t seem to make a difference whether constant power mode is on or not. On wood and slate the glitch is not all that noticeable but on stainless it is very obvious.

Also, I have noticed the quality of offset fill isn’t as good as normal fill and there is often a noticeable line in the middle of the fill.

I’d really like to use offset fill much more of the time because it can radically reduce run time. But not if the results are dodgy.

If that’s the case then this is likely a firmware bug.

Offset fill isn’t really considered a general purpose fill type. It’s meant to be an option on very specific scenarios where offset fill is the best alternative option. Sometimes offset fill can create odd or seemingly incomplete paths based on the shape being filled. Burn quality is typically compromised as well as compared to a standard fill since the laser head is nearly under constant acceleration.

Part of the problem is that XTool created their own firmware, so I have no way to know if their motion planning engine is doing what it’s supposed to. I’m not sure it even supports constant power mode.

As Berain mentions, normal “Fill” is always going to give the best quality output, because the motion is predictable and linear, the laser power is basically constant for the whole run, and these machines are intended to be used this way.

Offset Fill was added to help with designs where there’s a LOT of blank area with a thin border, like a picture frame, or when the quality of the engraving is less important than the speed - it’s a known tradeoff, and there’s not much I can do to change that.

Which version are you running? Some changes were made a version or two back to try to minimize the direction changes when using offset fill, so it’s less likely to do 90 degree corners when moving between contours, but that’s about as good as it’s going to get.

I understand. I’m running the latest ver. 1.2.01

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.