Offset for absolute coordinates? (home offset setting needed fix)

Somehow “user origin” is not working (behaves like “current position”) and isn’t the desired outcome anyway, here is my question:
Can I adjust the absolute coordinates somehow?
The pic shows the home position defined by the limit switches (red/green square). But the actual 0/0 of the cutting bed is where the Cross wit the red dot is.
How can I move the grid 0/0 to that position?
laser_origin
(FabCreator Kit KM6 with ruida board and lightburn 1.0.02)

I believe the Green is the project corner, red is the 0, 0. The last is your laser head…

When your machine boots, after it homes, does it make a quicker move to say 5, 40?

The Ruida will move the head to the origin when it’s done. If you have pressed the ‘origin’ button on the machine console, that’s where it will return after a job and after it boots. Looks like it’s about 5mm, 40mm from home.

It could also be current position = user origin.

What does the Ruida console indicate for the X and Y positions after a boot?

If you still have problems, check out Coordinates and Job Origin, assuming you’ve already followed the Ruida setup instruction

Interesting title for the question…

:smiley_cat:

The problem (was): I know the last is the laser head position. But was shown in lightburn wasn’t the physical position (that was 0/0 over the bed)

But, guilty as charged.

It was in the ruida settings. The machine comes as a kit, but with configured home offset and I assumed that those would be fitting. So the trick was:
Move laser head to the actual 0/0 of the bed, set it as origin, move it to origin position. use "get position from the “move” menu:
get_position
Now we have the values which to add to the existing home-offsets in the “Machine Settings” menu (in my case 3mm, so x=9.5 and y=25.5).
Write settings to the board.
switch the cutter off and on. (I closed and opened lightburn too, might be unnecessary).
This procedure is not explicitly mention in the manual, but it shows the home-offset value in the pics.

When I build a jig for holding something or using it you, I commonly set the Job Origin as ‘absolute’, which is what caught my eye in the title.

I’m not sure what you are trying to do, but it sounds like you are making it much more complicated than it is…

What part finally tipped you off to the issue?

Did you read the console after a boot to see where the head was?

Glad I could help…

:smiley_cat:

It was way more basic. After booting the home position of my physical machine was “off”
Something like this:


So, if you place a design in that corner, it will e partly engraved into the alu frame.
As the console stays grey(maybe I missed some setting here). So I moved the Laser in position where the absolute x/y should be, got that coordinates from lightburn and added that to the home-offset of the x/y-axis in the “machine settings”.
Next boot the laser stays in the correct place after bootup.

I still don’t have a clue as to what you are trying to accomplish.

You are set in ‘user origin’ mode, last I read, but keep referencing absolute coordinates.

What you are telling me might make some sense if I had an idea of the problem and what you are trying to do. I need some kind of ‘workflow’.

I’d love you assist, but you haven’t given me much to go on.

Why does it have to be at absolute zero?

What are you doing in relative mode that you need absolute coordinates?

Slow down and we’ll figure this out…

:smiley_cat:

Most important: my problem is solved.
My mistake: I did confuse “origin” vs. calibrating the machines home position.
The main obstacle was to find out how much the offset of the home position was. But that is more a problem of the ruida, since I couldn’t find a setup routine there.
Something like moving the laserhead in the home position and have a “this is the home position”-Button on the ruida board.
So I did move the laserhead in home position and used lightburn (get position) to read the value and fixed that in the machine settings and wrote that to the ruida.

I still have no idea of what you are trying to do.

can you elaborate?

Which machine settings?

:smiley_cat:

This was a problem with a physical offset in my machine, which I had to fix by writing new values for the home position on the firmware of the rudia board (that is the mainboard of the cutter).

I just used lightburn to get the value of those offsets.