Offset in the cut :(


i use lightburn on my Mac and my laser use a Ruida Controller.
First of all, when i draw a circle i have a circle and my squares are square with the good size.

Now, when i send my file to the ruida with Lightburn and there is a lot of shape to cut (my laser is very large), it start to cut on one side, go to the other, continue to cut and suddenly, the is an offset in the cut. But later it can do a good cut and remake an offset later…

My pictures will talk themselves.

When i send a small file with few informations there is no problem.
My files are created in AI format on illustrator.

Can you help me ? I send to the trash a lot of material… :frowning:


Capture d’écran 2021-03-19 à 18.42.51 Capture d’écran 2021-03-19 à 18.42.54

post the file you are using that you are having a problem with.

Your pics aren’t enough to work out the problem.

What controller (model, not just manufacturer) what laser - size, specification?

I have similar problem - when laser beam was not aligned to center of nozzle!


thanks for you answers.
I found the problem, but not the solution. If lightburn dev have an idea…

Here is what i found :

When i send a lot of model to cut to the ruida (version RDC6445) it’s like there is too much informations and the laser makes mistakes.

I tried to cut my files and cut less models there is no problem.

If you see my file, i will cut the color one after one and not in one time.

Can we set the amout of memory ? Is there some limits ?


Hi Fred, as a single file / project it should not be a problem with memory. I work with similar files with a MiniGerbil without any problems. Can a Ruida controller’s internal memory be “cleaned up”?

I registered here just to find a solution for the same issue, X axis offsets when lasering large jobs. Then I found out either here or somewhere else Mrs Google would take me that the Ruida USB connection does not use communication error correction, and via LAN uses UDP instead of TCP/IP. Both links enable packet/transmission losses. Likely no problem low complexity jobs, but surely for my bitmaps or something complex like @MonsieurFredo’s work.

This is my solution which worked for me, using the only left option to get the job into the controller after USB and LAN disqualify: saving the RD file to a USB stick within Lightburn, and then plugging the stick into the UDisk port on my machine. From here I could copy the file to the internal file memory, and I could start the job from there (press Origin to mark the starting point after positioning the head).


UDP works fine on the ~1M installed Ruida controllers.

Packet loss isn’t an issue in a local LAN, unless you have massive EMF problems or really bad cables or a faulty switch.

The Rudia controller uses USB1.0 - not designed for high speeds and lots of data - but a good quality cable with chokes fitted should make that a non-issue.

People overthink such things - this hardware is proven. If you are having comms problems, much more likely to be your computer or the cables than the Ruida.

Well, UDP can be a problem if your PC/laptop connects to the router in a busy Wifi environment with poor signal levels. But let‘s not argue over technical possibilities and impossibilities.

In my case (ie my machinery) I often had offsets when using USB with bitmap/raster image jobs (ca. 3 out of 4), and so far never when transferring the job via Udisk. Maybe this works out as well for someone having the same issue on his machine.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.