Omtech 100w with ruida control USB driver not working

Hello, trying to set up my new laser. i’m trying to connect it via USB and the computer sees that i have connected an unknown device. once i install or update the drivers it then says that the device is unable to communicate. Lightburn obviously cannot find the laser as well. i used the drivers that came with the laser and the driver that lightburn installs as well…brand new to this stuff so kinda clueless

I know it’s not what you’re asking for, so sorry about that, but why not use your lan? It is faster and significantly stable as usb. And the setup itself has (here at least) been hassle-free.
Another thing is, I do not remember installing a driver for my Ruida machine, on either my Mac or on the workshop computer, an old Dell with Linux Mint.

Are there 2 USB’s on the laser? They are not the same. One is for usb flash drive and the other is for PC.

tried the lan, still doent find or communicate. i did set the ip address. on the bottom right corner of the control screen says LAN:off.

Have you tried manually creating a profile for your Ruida?

actually, if you plug the other end of the lan cable in, seems to work just fine