OMTECH 150W wont connect to Lightburn

Hey all, I recently got a 150W OMTech and got it all set up and had it working. Last night switched out and put my rotary in and went to change my machine settings and ever since last night get a “Communication with Controller Failed”.

Everything I have tried:
removing and readding the device to lightburn
reset params
trying tnew usb and ethernet

none have worked. any help?

If you stick with Ethernet, you don’t have driver concerns.

I have a Ruida and as far as I know there is no relationship between settings for a rotary and how it communicates… Suspect it’s coincidence somewhere.

Have you used both Ethernet and USB on your machine? Which do you use most predominately?

Do you run your Ethernet via your local lan or direct connect?


I have actually gone ahead and took my raspberry pi off my 3d printer and did a lightburn bridge to my machine and got it working again!

That is the best approach… USB is a real pain, but the bridge works great…

Glad to hear it’s talking again…

Have fun


Thank you for the reply! I was so annoyed I wasnt able to get it to work and never heard of the lightburn bridge until 10 posts deep on here and decided to do it!

It should work on your network, as far as connecting goes… It’s doing that with the PI anyway…

One of the issues is that it’s a static IP on the Ruida and most home lan systems expect it to be dynamic IP. When I did have it connected, on my routers view of things I can right click and bind it’s IP to it’s MAC address…

You’re up, and that’s what counts…

Have fun


Thank you! Some good info.

I keep having to rescan and reconnect as it keeps disconnecting from it right now but it works when i do that so not too concerned right now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.