OMTech 60W Ruida RDC6442G-B (EC)

When I hook up my laptop (Dell Win 10 USB/Serial) to my OMTech LightBurn will rotate my images/projects upside down and mirror them. When I switch back to my Atomstack it shows up normal. This causes a big issue when I try to laser my project. Things are not where they should be. When I frame an object it is way off. When I try to laser something it will throw an error that it is out of the field. The only way I can get it to work is by using exact coordinates. Why does everything switch when I chose the OMTech device? Also, Origin is set to back right. That is where the laser goes when powered on.

I should note, this happens even when it’s not directly connected to the laser. It happens when I select the device.

The origins a different… You are operating in a different quadrant…


The Atomstack is a front-left origin machine. The OmTech based on your description is a back-right origin machine. Because of these differences the designs in LightBurn themselves are oriented differently. So when you design in one and switch to the other the orientation of the design will change.

Some changes were introduced in 1.3 that will automatically reorient a design that is saved in one origin and loaded in another.

However, if you are actively working in a design and then change devices dynamically the orientation will follow the change in origin since you’re actively requesting the origin change by doing that.

Either start designing on the target machine and use save/open when switching machines or just be aware that you need to change orientation based on origin of machine. Also note that workspace area is also relevant here. Designing for a larger workspace and then loading to a smaller will leave your design outside the workspace.

I understand the origins are different as well as the workable are. However, that doesn’t explain why any project imported to lightburn when that device is selected gets turned upside down and mirrored. It’s like something is up with the Y-axis. Also when I frame an object before I am ready to laser it will frame a completely different spot if any spot on the workable area. It tries to frame a location that isn’t even there. Ignore the Atomstack reference for now. I can create an image or even a simple square in lightburn when I am on the OMTech device and it will not frame or go to that object. It thinks the object is somewhere else.

Might be a good idea to check out Lightburn for the setup of the Ruida and the coordinate system.

You operate in one of 4 quadrants. If you design it in quadrant 1 then change the software to a different quadrant, such as quadrant 2, the art will be mirrored across the Y axes…


It sounds like there may be 3 separate scenarios going on?

In what way is this not explained? Not following that part. What version of LightBurn are you running? If you’re running anything older than 1.3 the import should appear rotated 180 degrees.

I want to make sure I understand. You’re saying the Omtech is select in Laser window. So in your current design you have an object placed at a particular location. But it’s framing somewhere else on your actual laser bed?

This sounds like it may be the same as #2 above but want to confirm. Even if you have not imported the design, as-in you create the design new for the Omtech you’re having this problem?

Can you provide the following:

  1. screenshot of Edit->Device Settings for the Omtech
  2. full screenshot of LightBurn with design loaded and Laser window showing
  3. photo of your laser bed after homing
  4. photo of burned design or some other indication of where the framing took place

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.