OMTech K40+ , Laser will not fire

I have a OMTech K40+, which has the upgraded controller for LightBurn.

The laser head will move, however, the laser will not engage when you hit start. I have checked the machine settings and The “Laser Mode Enable” is checked.

Is there something else that I need to check?

I have lightburn version 1.4.01

Hello, welcome to the group…

Has it ever worked since the controller update?

How are you wired to the lps from the control board… do you have a power adjustment pot?


I bought this unit brand new from
OMTech with the upgraded controller.

It has not worked correctly from day one… If I hit the test button, it will fire, however, it will not fire using any software.

OMTech sent me a new Laser Power Supply unit to see if that was the issue…same problem

The photo is the control board

We have to know how it’s wired, maybe OMTech can help you find the information. I can’t tell anything useful from the photo you posted.

The lps has two control lines and a common ground. The control lines are pwm and laser enable.

These can be wired in multiple ways, but generally the K40 has a voltage divider (pot) to control the IN pin voltage of the lPS. This is the current limit voltage.

The Laser enable is driven by the pwm output.

There is something missing in how you wired them, since it will lase with the test button…

Back to how is it wired? Do you have a link to a video or something on how you did the upgrade?


OMTech will be sending a new motherboard, now.

OMTech is just telling me that it has a K40 Nano mothboard, at the moment.

I just ran another test using the square. I

opened lightburn for this test, however, it does not matter what program I use, the result is the same…the Laser does not Fire.

Everything below “$32=1” is the program burning the square.
The result was movement of the Laser head but no laser burning to form the square.

Hopefully the photos below will help.

OMTech will be shipping a new K40+ to replace this one…they could not figure out what was going on.