OMTECH K40 only cuts in upper left corner

I just got this laser, I’m new to Lightburn. I’m trying to set up the laser cut area but it only cuts in the upper left corner, I’ve read a number of posts, put it in ABSOLUTE COORDs no matter where I draw a test object it always cuts in the upper left (towards the back) I tried reversing origin nothing changes. Please help me figure this !@#$%^&*( thing out.

You sure it is a GRBL controller?

Enter $$ in the Console window, then copy-paste the result here.

$$

$0=10

$1=25

$2=0

$3=1

$4=0

$5=1

$6=0

$7=0

$8=1

$10=1

$11=0.010

$12=0.002

$13=0

$20=0

$21=1

$22=1

$23=3

$24=200.000

$25=3500.000

$26=250

$27=3.000

$30=1000

$31=0

$32=1

$33=4000

$34=0

$35=5

$36=100

$40=1

$41=1

$42=0

$100=157.500

$101=157.500

$102=157.500

$110=18000.000

$111=18000.000

$112=18000.000

$120=2000.000

$121=1500.000

$122=500.000

$130=300.000

$131=200.000

$132=300.000

ok

GRBL, yes.

Can you upload the Lightburn file that is doing this?

I’m not using any file, I’m just drawing a shape on the panel (?) I’m trying to get it set to cut 1/8" light birch ply (which is a whole other issue)

It becomes a file when you save it. Save it, then upload the copy to the posting reply.

Test.lbrn2 (2.7 KB)

New file to test.

Click on the oval and Frame it. Where does it Frame based on the markings in the drawing?

Adjust the power to what you think is right for the material (or set it at 1%) and hit the Start button, Does it run in the same location as the Frame did?

I will be checking for your reply in the morning (10am EST, about 2pm GMT).

Rebidoux Test.lbrn2 (27.5 KB)

Sorry for the delay Mike, been busy with work and such. the oval is cut in the back left corner

These were related questions. Please answer.

It should have run in the front left area. Where does the machine go when you click on the Home button?

Oval showed on the screen in the front left, laser cut the oval in the back left

You are making me ask questions twice. We need this info to determine if your coordinate system is set up properly. It will help determine what needs to be done to get you up and running.

I apologize Mike, I did not see the question regarding the HOME travel.

When I hit the HOME button it travels to X-0 Y-200 The Back left corner

Ok, now I am getting a better picture of what you have. If you rotate the machine 90 degrees clockwise, the front-left becomes the back-left position.

  1. Can you send me a screen capture of your Lightburn window just like the one I sent you? Include all the stuff at the top and bottom.
  2. Also, send a picture of the machine from the front as you use it. If it has a cover, have the lid open.
  3. Does the Jog work okay, or does one of them seem backwards?

The goal is to get you working in the +X+Y quadrant because that is where Lightburn has to work.

Hang in there, we are making serious progress now. It appears a change in parameter settings can get it working.

Sorry for jumping in, but your machine origin is set to left front when you said it homes to left rear. I can tell that by the location of the red square in the corner of your work area. You need to set your machine origin in device settings properly. See screenshot.

1 Like

That was next. I wanted to make sure he had not physically rotated the machine on the table.

But jumping in is good.

2 Likes



I’m sorry if this is the wrong screen shot you’re looking for. not sure which one you want

From the location of the home switches in the photo, I’d think your machines origin appears to be back/left, not front/left… might check that out…

:smile_cat:

Okay, we have the machine placed properly. Did you set the Origin in the Device Settings window like @thelmuth suggested? This will help the workspace match the machine.

Which axis was the Jog backwards? Sideways is the Xaxis and front-to-back is the Yaxis.