Open Builds Black Box X32

Current version of LightBurn and having connection issues with Open Builds Black Box X32 controller. Fire button is enabled in the software but laser doesn’t fire and sometimes on Console tab there is no connection and not able to move the laser across the work piece.
Any Help Appreciated

I don’t know much about these, but what process (guide) did you follow to configure it?

Has this run on other software or is it new?

It sounds like it connects sometimes, but drops it?

Did you go through the Lightburn grbl setup?


Ok, was messing around last night and everything ran fine except the “Fire Button” in the software. It is enabled in the Device Settings tab but doesn’t work no matter what power percentage I set.
I’m going to cross post in the OpenBuilds forum because it’s their controller but everything worked fine with my X-Controller before the Blackbox.
I currently have GRBL v1.1f and see that there is a version 1.1h, should I update?

Thanks for your reply.

I think the f version is still ok, but I’m not really sure…

When you created the ‘device’ which grbl did you choose? Some use different gcode to enable the laser …

Maybe @berainlb knows about this board and can better guide you…


1 Like

I’m not very familiar with this specific controller but I suggest checking the basics.

What are the values of $30, $31, $32?
What is S Value Max set to in Edit->Device Settings?

S value max is 1000

1 Like

That’s interesting. First off, set S Value Max to match $30, so should be 255.

However, I don’t see how this would have prevented the Fire button from working. If anything I would expect this to basically make everything over about 25% full power. The power levels at Fire button levels should have made the laser fire more than expected.

Have you tried running a job? Does the laser fire then?

Anyhow, give it a try and report back behavior after making the change to S Value Max.

1 Like

Yes running a job works, just the fire button not working and it makes setting up work piece harder.

The OpenBuilds BlackBox X32 runs on a cutting edge modern firmware called grblHAL grblHAL · GitHub
This is copied from the OpenBuilds website in the documentation tab for the controller. Don’t know it this has something to do with it or not. I’m not versed in the technical aspect of this.

I saw that they were using grblHAL which surprised me that there were some legacy GRBL conventions in what you were describing.

If this is working for a burn there should be no reason it shouldn’t work with the Fire button.

Can you provide the following:

  1. screenshot of Edit->Device Settings
  2. full screenshot of LightBurn with Move window showing
  3. push “Show all” in Console, then engage Fire button, then disengage. Go to Console and copy all the output from the time you clicked Show all until end and paste here.

Hope this helps.

Change S Value Max in Device Settings to 255 and retest.

Test higher power % up to 20%.

I don’t see any reason why it wouldn’t work unless your controller doesn’t support M3 which is unlikely.

Changed S Value as suggested and upped to 25% still no fire button.

will be away from shop a bit, so will check back in later


Try running this in Console:

G1 F100 S10

If that turns on then turn off with:


If that works then there’s likely something wrong either with the controller or the laser module.

Do you have a meter you can use to test voltages for PWM output?

Ok pumped up fire button power to maximum I guess - 20% and my overhead work lite was off and I did see a faint beam of light when hitting the fire button. I think all is working but with my old X-Controller and Lightburn, I never had to pump the number up that high.
Mystery solved I guess.
Thanks for the reply’s and the learning experiance.

I thought you had a 32 bit board.

Maybe @berainlb can confirm or deny, but I though you’d want a 0 to 1000 range over a 0 to 255 range for a 32 bit board…

I’d think the lasers range would be the same, just less steps between no power and full power.


It is 32 bit board, but that tech is above my pay grade. I’ll wait and see if he chimes in on that one.

I would have thought the same. But $30 was already set to 255. That was one of the things I was referring to when I said there were some legacy GRBL conventions so not sure what’s happening there.

Should I try to change $30 to something higher? the 255 was set from the old X-Carve controller. I just backed up GRBL from it and restored to the BlackBox when I switched over.

Ah, that means you overrode existing values.

Taking a look at Openbuilds documentation looks like $30 default is indeed 1000.

  • To Activate the signal, send an M3 Sxxx where X=0-1000 (1000 = default Grbl configuration, or send S=what you have set for $30 - Max spindle speed, RPM). For example, to have a 10v output send M3 S1000, to have a 5v output send M3 S500, to have a 1v output send M3 S100 etc. (NB scale accordingly if your $30 is not ‘1000’)

So yes, change $30 to 1000. Also change S Value Max to 1000. Then retest.

Ok reset values and Fire button works but intensity at 20% power is no different than the 255 value. All good as long as I can adjust work piece to the laser now.
Thanks again.