Open shape issue

I have been struggling with creality workshop to run laser cutting, then after a long gap came across lightburn.

Wonderful software, but I am unable to simply get the shape closed.

Running 5w laser module on my modified ender 3 v2 (marlin)
220x200mm workspace

Noticed the start and end point of the shapes do not meet. leaving tabs.
Have tried numerous ways to solve it, toggled tabs settings, checked backlash, checked acceleration, direction change speed, power settings, no. of passes, studied various topics here on the forum. I am yet to get this solved. Truly amazed by the community trying to solve issues and keep the spirit of maker-mind alive.

Seems like the laser fires too early/too late or changes direction too early

Initially assumed this issue is only for dxf imports, but noticed this with shapes drawn in the lightburn tool too.

AutoSave_65ac.lbrn2 (34.4 KB)

Would appreciate any inputs and helps, noticed a few have faced this issue, but I am unable to come to an conclusion.


Open shape is a term when the tool paths enclose the whole shape…

I see the output isn’t closing the object but I don’t see an issue within the source you posted…

Even the art that is turned off looks ok…

Maybe @misken has some clue as where to look… I’m not really a grbl person.

Good luck

:smile_cat:

The shapes are closed in LightBurn, which means that the machine is unable to follow the commands used to draw them, which means there’s a mechanical problem.

The inner loops of the Lambo script show the same problem.

Given that it’s an Ender 2, take very a careful look at all the screws in the pulleys / couplers / eccentric wheels in both drive trains, because at least one screw is loose in each axis.

If the figures are oriented the way I think, the pulley on the motor slinging the bed back & forth has a very loose setscrew.

This is written for Sculpfun machines, but you’ll recognize most of the parts:

The key is to be grindingly thorough while testing everything for mechanical play.

Good hunting …

2 Likes

Click Save GCode and post here the file and your Ender Marlin Device (.lbdev)

What Power Modes are you using?

1 Like