OpenBuilds BlackBox controller issues

Ok let me start by saying I had previously had this same BlackBox controller set up on an old Ender 3 using all its hardware. I had no problems using lightburn to run this controller then (back in Dec of 2019).
I recently purchased a K40 laser and just finished scrapping the controller and replacing it with the same BlackBox controller. The only thing different really is that I had to flash the firmware to make it a two axis machine verses a 3 axis. I can do everything manually including homing, moving x and y and fire the laser. But when I go to run anything even a simple circle I immediately get a fault. Here is the code from the last time I tried… (PLEASE ANY HELP WOULD BE GREATLY APPRECIATED!!!)
Grbl 1.1g [’$’ for help]

[MSG:’$H’|’$X’ to unlock]

error:9

[MSG:Caution: Unlocked]

ok

ok

<Idle|MPos:-295.001,-4.999,0.000|FS:0,0|WCO:0.000,10.000,0.000>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-4.999,0.000|FS:0,0|Ov:100,100,100>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-3.999,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-4.999,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-14.998,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-25.000,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-34.999,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-285.001,-45.001,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-275.002,-45.001,0.000|FS:0,0>

ok

<Idle|MPos:-275.002,-45.001,0.000|FS:0,0>

ok

Starting stream

Stream completed in 0:00

<Idle|MPos:-275.002,-54.999,0.000|FS:0,0|WCO:0.000,10.000,0.000>

ok

Starting stream

Stream completed in 0:00

Starting stream

ALARM:2

On or near line 2:

Stream completed in 0:00

[MSG:Reset to continue]

Here is the g.code it is trying to run…
; LightBurn 0.9.10
; GRBL device profile, absolute coords
G00 G17 G40 G21 G54
G90
M4
; Cut @ 1000 mm/min, 8% power
M9
G0X23.07Y18.21
G1X22.18Y18.78S120F1000
G1X21.37Y19.43
G1X20.63Y20.14
G1X19.96Y20.91
G1X19.66Y21.31
G1X19.39Y21.73
G1X19.13Y22.16
G1X18.9Y22.61
G1X18.7Y23.06
G1X18.52Y23.53
G1X18.36Y24
G1X18.23Y24.48
G1X18.13Y24.98
G1X18.06Y25.48
G1X18.01Y25.99
G1X18Y26.5
G1X18.01Y27.01
G1X18.06Y27.52
G1X18.13Y28.02
G1X18.23Y28.52
G1X18.36Y29
G1X18.52Y29.47
G1X18.7Y29.94
G1X18.9Y30.39
G1X19.13Y30.84
G1X19.39Y31.27
G1X19.66Y31.69
G1X19.96Y32.09
G1X20.63Y32.86
G1X21.37Y33.57
G1X22.18Y34.22
G1X23.07Y34.79
G1X24.02Y35.29
G1X25.02Y35.71
G1X25.55Y35.89
G1X26.08Y36.05
G1X26.63Y36.19
G1X27.18Y36.3
G1X27.75Y36.38
G1X28.32Y36.45
G1X28.91Y36.49
G1X29.5
G1X30.09Y36.49
G1X30.68Y36.45
G1X31.25Y36.38
G1X31.82Y36.3
G1X32.37Y36.19
G1X32.92Y36.05
G1X33.45Y35.89
G1X33.98Y35.71
G1X34.98Y35.29
G1X35.93Y34.79
G1X36.82Y34.22
G1X37.63Y33.57
G1X38.37Y32.86
G1X39.04Y32.09
G1X39.34Y31.69
G1X39.61Y31.27
G1X39.87Y30.84
G1X40.1Y30.39
G1X40.3Y29.94
G1X40.48Y29.47
G1X40.64Y29
G1X40.77Y28.52
G1X40.87Y28.02
G1X40.94Y27.52
G1X40.99Y27.01
G1Y26.5
G1X40.99Y25.99
G1X40.94Y25.48
G1X40.87Y24.98
G1X40.77Y24.48
G1X40.64Y24
G1X40.48Y23.53
G1X40.3Y23.06
G1X40.1Y22.61
G1X39.87Y22.16
G1X39.61Y21.73
G1X39.34Y21.31
G1X39.04Y20.91
G1X38.37Y20.14
G1X37.63Y19.43
G1X36.82Y18.78
G1X35.93Y18.21
G1X34.98Y17.71
G1X33.98Y17.29
G1X33.45Y17.11
G1X32.92Y16.95
G1X32.37Y16.81
G1X31.82Y16.7
G1X31.25Y16.62
G1X30.68Y16.55
G1X30.09Y16.51
G1X29.5Y16.5
G1X28.91Y16.51
G1X28.32Y16.55
G1X27.75Y16.62
G1X27.18Y16.7
G1X26.63Y16.81
G1X26.08Y16.95
G1X25.55Y17.11
G1X25.02Y17.29
G1X24.02Y17.71
G1X23.07Y18.21
M9
G1S0
M5
G90
; return to user-defined finish pos
G0 X0 Y0
M2

The machine is in negative workspace coordinates, and you’re trying to run a job in Absolute Coordinates, meaning it’s going to try to run in positive space.

ALARM:2 is out of bounds.

Read about offsetting the workspace here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

1 Like

Great, Thanks Oz, I thought it had something to do with LB not using Cartesian coordinate system but wasn’t sure how to overcome. I tried switching directions in firmware and a bunch of other things that didn’t work but this worked perfectly! Thanks Again!

I am still trying to find the right way to use “origins” and “finish position” but as long as I don’t use either of those it is working.
I’m still testing but I may have some questions about improving start and top timing of laser to get rid of missing or weak power at corners and such.

I’ve you’ve set up the offset, and set $10=0 to report positions in the right coordinates, the origin and finish position options should both work.