Orientation and upside down letters

I just got a Neje max 3 and am using lightburn. I have set my origin to all positions, it will not wright words in order, its either backwards, upside down or both. Also when i click to locate the laser in the top left on LB it goes opposite. Any help is appreciated

Does that machine home?

Lightburn and the machine need to understand each other, so you need to determine where you machine ‘homes’ or where you physically home it. One that’s determined you can set the origin properly in the device settings.


I’m not good with GRBL machines. I have a CNC that sits because it frustrates me. Based on your user info that is what you have. I don’t mean to point out the obvious but have you gone through the setup documents? I had to go into machine settings and change some things to get mine to run the right directions but I have Ruida controller.

This has a lot to do with telling the program how the machine is set up.

Yes it does home. I have set the home position in the top left but it goes “origin” in bottom left. Its almost like the axis’ are flipped because if i manually tell it to go to top left corner it goes to bottom right and vise versa. Iv went to settings to change point of origin but when i do that it changes the text iv written to upside down or backwards or both.

Thank you! I will look into this.

Can you take a screenshot of the Device Settings window?

If I recall, Neje 3 Max homes to top left. Can you confirm?

Also, what is reported position in Move window after pushing “Get position” immediately after a homing operation?

This is a screen shot of my device settings and position after homing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.