Origin wrong direction

New to Lightburn and lasers and having some difficulty getting set up.

Something is wrong with my origins. Not sure whether it’s in my Lightburn software setup or my machine setup. When homing, the machine goes to the front left corner of the machine and continues to slam against the rail looking for the home position. If I escape, I can reset the X axis fine.using the axes reset command. But when trying to reset the y axis, it just slams into the front of the machine. My Y homing sensor is in the back right of the machine, so I’m not sure how to properly set this up.

You might need to invert the Y homing direction in the vendor config. Did your machine come this way, or did you install the controller, reset the settings, or something else like this that might have corrupted what the manufacturer set up?

This might help:

When I got the machine, it was working correctly but when I went to engrave, it was backwards and flipped. I had a friend change some settings in Lightburn and it engraved in the correct direction, but then the homing issue started. I tried to reinstall Lightburn to resolve the issue but it didn’t fix it, and now the engraving is flipped and backwards again.

Changing the hardware settings was the wrong way to fix it in the first place, so try this:

  • In LightBurn, go to Edit > Device Settings
  • Move the ‘Origin’ dot to match the corner that your machine seeks out when first powered up (the corner where the homing sensors are)

That will make the engraving match the display in LightBurn. At that point, sometimes the display on the controller itself will be wrong. If that happens, press the Z/U button on the controller, find the ‘Screen Origin’ option, and change that to match everything else.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.