Ortur Laser Master 2 20W (2021 version) not recognizd or responding to Chromebook running Linux

I’m running Lightburn Linux on my 2020 Chroembook. I’ve successfully installed the software and manually added the Ortur Laser Master 2, but it isn’t responding. I’ve gotten the laser to work using the Mac version of Lightburn on a Mac laptop, but now I’m struggling to get it to notify the laser on the Linux version.

I am able to open and run the software and manually add the laser on my Chromebook, but the laser doesn’t respond. I enabled Linux, successfully ran the command to adduser dialout and tty; I’ve also updated and upgraded my linux terminal; i’ve manually added the Ortur Laser Master 2 20W (2021) to lightburn, but it isn’t communicating with the laser even though the laser indicator lights are changing colors (Green and Purple) when I plug them in to the USB.

Any help is appreciated. I am new to Linux. Thanks.

What does it mean to log out and log back in? Does that mean log out of light burn and log back in? Or does it mean logging out and in to the Linux Terminal? New to Linux. Got the software up and running on my Chromebook. The color on the board are green and pink, but it’s not responding.


When i plug the laser in to my mac, i select the laser, and then the drop down menu next to “Devices” fills in and says “cu.usbmodem00…”. When I plug in to my chromebook, the drop down menu next “Devices” remains as “Choose” with no other options.

On a normal Linux computer when someone says to log out and log back in it means Linux. Since you are running Linux inside a virtual machine on a Chromebook, you might get away with closing the terminal window and starting a new one. There is no login for LightBurn.

I know my way around Linux pretty well so hear are a few things to try and verify things are setup.

After you add your user to the dialout group, exit the terminal and start a new one then type “groups” to see if dialout is in the list of groups.

Next, without the USB plugged into the computer, power up your Ortur and then plug the USB cable into the Ortur and into the Chromebook.
Now type “dmesg” in the terminal window and look at the last few lines displayed. You should see something like “[75986.345200] cdc_acm 1-3.1.2:1.0: ttyACM0: USB ACM device

Now type “ls -l /dev/ttyACM0” and you should see something like “crw-rw-rw- 1 root dialout 166, 0 Jan 8 19:17 /dev/ttyACM0

These all validate the dialout group is being setup for the user and the Ortur device connection. You should then setup the /dev/ttyACM0 device in Ortur when you setup the device connection. Or whatever device name was shown on your system.

the device name, ttyACM0 in my case, is the device name you should see in your LightBurn Devices drop-down list.

This is enlightening, but I’m afraid I wasn’t able to find it. I ran “groups” command, i see ‘chronos-access android-everybody tty dialout cdrom floppy sudo audio video plugdev users kvm’ ; I found ‘cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters’ but nothing else for cdc_adm.

When I ran the “Is -I/…” command, i see “-bash: Is: command not found”. I’m assuming that’s because I can’t find the ttyACM# in the dmesg.

When you say in your third paragraph to ‘setup the /dev/tty/ACM0 device in Ortur when you setup the device connection’ does this mean as the device name in Lightburn? Hoping to learn what to do here in case this noob ever does figure it out :slight_smile:

Also, I found this link on the Google Support forum complaining about the December 2020 Chromebook update breaking USB for Linux. I’m guessing this might be the true root cause.

Thank you, Doug, so much for your quick, clear, and thoughful response. I appreciate it and will continue working through the instructions.

you showed “dialout” listed in the output from the groups command…

you were to be looking for something like ttyACM0 in the output from the dmesg command.

Another way to look at what your computer is seeing being connected is to unplug the Ortur, run the dmesg command and LOOK AT THE LAST FEW LINES… then plug in the USB cable and run the dmesg command again and see if those last few lines are different. If they are then your system at least recognized SOMETHING was plugged into it. If you don’t see it then the problem runs deeper.

FYI, you did not execute the proper "ls " command. Please try to be accurate in what you are doing.
You can google all of these commands and read about what they do. A good way to do it would be to use name Ubuntu before the command. Like “Ubuntu dmesg” or “Ubuntu ls”. FWIW, the ls command lists things and the “-l” option is to give the long listing. The last part of the command is the thing to be listed. If you’d seen a ttyUSB0 or ttyACM0 in the output of dmesg then listing the device file found in the /dev directory, like /dev/ttyUSB0 or /dev/ttyACM0 would have provided the long listing for the device which would have shown the user and group attributes for the device. We wanted to see that the group attribute was set to dialout.

Yes, if there was a failure in the USB subsystem then that is why you did not see any USB device information show up in the output from the dmesg command. You are on the right track.

1 Like

Thanks. Testing again. The light on the Ortur board changes when I unplug the USB from my computer, but I’m assuming that’s because it’s deriving some power from my chromebook.

Just ran dmesg 2x (plugged in and not plugged in) and a quick scan of the final 20-ish lines are identical, so it appears the chromebook isn’t recognizing the USB device.

I’m open to any suggestions on the next steps. Appears it may be a Chrome OS issue?

1 Like

if you don’t have the power supply plugged into your Ortur then yes, the USB port is supplying power. That’s why I generally tell people to power the Ortur first and then plug in USB. If your Ortur does not automatically home when you turn it on, something is wrong as the firmware should do that without any computer connected.

FYI, from what I’m seeing, the ability to enable USB support for “experimentation” has been removed from the recent ChromeOS update and they now only allow tablets and phones to connect to it. They are getting flack for this since many want to do things like program Arduino, communicate with USB serial devices and like us, want to communicate over a USB serial device to the laser cutter.

I don’t have a ChromeOS device to experiment with so all I can do is search forums. There are device rules which usually are used for specific devices and should be in a directory found here:

If there was a file there with the following line then there might get created a device named ortur in the /dev directory. This would happen because my Ortur has a USB product ID of 5740 and a Vendor ID of 0483. I expect yours would be the same.
SUBSYSTEM==“tty”, ATTRS{idVendor}==“0483”, ATTRS{idProduct}==“5740”, MODE=“0666” , SYMLINK+=“ortur”

Other than that, the next best thing to do is to follow some of the links which let you tell the Costini developers you want to use your USB serial device to stream gcode to your laser cutter. It’s really a very generic USB device which is created and used to communicate with the laser.

Thank you so much. I’m going to follow these steps now.

Would it be different if I connected my Ortur through the USB-C 3.1 port in my chromebook instead of the USB-A 3.1 ports?

Never mind on the udev rules test. I just saw that they disabled USB pass-thru which prevents the version of Linux running the Chromebook to pass through to the Costini virtual machine so that it recognizes the USB devices.

It used to be there and was listed with an Experimental option in the Costini Settings but they removed it.
So it’s looking like for now, either you have to put full Linux on your Chromebook or wait for Google to start allowing USB pass-thru again.

UPDATE: no it would not matter what USB port you connected to.

1 Like

Thank you so much. Guess I’ll be researching Linux on my chromebook and can always fallback on my older computer that’s relegated to my kids. Bought the chromebook a year ago for mostly web browsing but started getting in to this space recently and would love to be able to create.

Thank you, again, for you help. This has been a great learning moment and gives me several tools I’ll be able to use as I continue to learn more.

1 Like

If you see v88 of ChromeOS update get released you might try it again. I did see some mention of USB Serial in the source code which could mean they’ll enable more than just Android phones and tablets. Maybe…

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.