Ortur Laser Master 2 y axis stop not working

Hello everyone, I’m new to the laser community and just set up my Ortur Laser Master 2 20w laser. The issue I’m having is the laser will not home to the front left of the machine using lightburn. The laser moves fine and will fire a project if I change the start position to anywhere other than the home position. It worked initially then just started making a loud noise and not stopping when the Y-axis stop switch was engaged in the home position.

I’ve triple checked the wiring harnesses and ensured I have the current firmware for the laser and the most current version of Lightburn. At this point, I’m thinking of ordering a new Y-axis stop or just manually changing the home position in Lightburn. I’d greatly appreciate any assistance or advice to correct this.

The code below is what appears in Lightburn.


Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.


Ortur Laser Master 2 Ready!

OLF 140.

Grbl 1.1h [’$’ for help]

[MSG:Check Limits]

[MSG:’$H’|’$X’ to unlock]

[MSG:Caution: Unlocked]


Hi, have you checked the ‘device settings’ at the top of lightburn (spanner and screwdriver) make sure ‘origin’ is in the bottom left circle.
Check the ‘width and height’ are also correct.

You said you checked the wiring but check the plug on the end of the gantry it often comes loose and causes the laser to keep going when it hits the left side framework.

Thanks for the quick reply Chris,

I’ve checked every wiring harness at each location multiple times, but checked again with no change. I’ve read that certain ones keep disconnecting so I’m 3D printing some parts to help with the cable management now.

I looked in the Lightburn device settings and it seems correct, origin is set for the front left with the dimensions being correct at 400W x 430L.

Just out of curiosity, if I set the origin to any other corner shouldn’t I just be able to bypass the Y-axis stop switch all together? I’ve read some commands to tell Lightburn where home is for older machines with no Y-axis stop switch, but I don’t know enough about that and didn’t want to try it.

Sorry you couldn’t solve the problem yet, I believe you can set ‘home’ pretty much anywhere but I wouldn’t like to say how, i would just be guessing.
Someone will be able to tell you.
Good luck.
P.s i’ll have a look around see if i can find how to set ‘home’.

Turn off ‘auto-home on startup’ in ‘device settings’.

Machines without homing sensors / limit switches

If your machine does not have homing switches (also called limit switches) you will need to home it manually if you want to use Absolute Coords or User Origin modes. You can do this in a couple ways:

  • With the machine off, manually move the laser head to the origin position (usually front-left), then power up the machine. Until you tell it otherwise, the power-on location of the controller is treated as the zero position.
  • With the machine powered, jog the laser head to the origin position. In the console window, type: G92 X0 Y0 and press (enter). The G92 command tells GRBL to set the current location as the specified coordinate, so you’re telling the machine “this is zero”. You will also need to set $10=0 for this to work correctly.
    Hope this works until you can get it fixed.

Thanks again for taking the time to assist, I just turned off the auto home on startup.

My laser does have the Y-axis stop switch, I just do not think it is functioning. The X-axis has a light that comes on when the stop switch is pushed, nothing comes on when the Y-axis switch is pushed,

I just put the laser together two days ago and am learning what I can through YouTube and now this forum. I will try the command you sent and see if that helps. I want to get it up and running, but want to find the issue more since it’s a new machine.

Hopefully @OrturTech can help, or you can reach Ortur support at Ortur Customer Support – Ortur Support Ticketing System
From what I have gathered from this forum they seem to be pretty good at supporting their hardware.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.