Ortur Laser master 3 stop mid program. USB connection

Please read the Email I sent to LIGHTBURN and Ortur regarding my Laser master 3 issue. The email was promptly responded to by lightburn.

They recommended connecting via WI-FI. Here’s the link they sent me. Ortur LM3 WiFi access - #12 by brewster
Any other advice regarding USB connection would be appreciated. Apologies for the wordiness.

I purchased the laser master 3 pro about a month ago, and so far I am very pleased with quality of the engraving. However, I have been trying the LIGHTBURN for the operating software, and have had a particular issue. With or without the laser on, and at various speeds the laser will stop moving mid program (anywhere between 1 minute and 22 minutes, an average of 9 minutes) and eventually return to origin. The USB connection drops, as a pop up appears in the bottom right hand corner of screen, indicating it is reconnecting. Previously, I used LASERGRBL and had no issues. I have been pretty committed to utilizing the advanced features LIGHTBURN, as you’ll soon read.

The message displayed on LIGHTBURN’s console page simply states “connection lost” “port opened?”. The machine will then reconnect and reorigin. This sometimes takes minutes, sometimes seconds. I have also seen the USB connection disconnect without the laser being commanded.

I am currently using the free trial on lightburn V 1.2.04.

I am using Dell Latitude 5531 laptop with Windows 10.

What I’ve tried so far:

Verified power supply voltage 24.0V. Replaced anyway, to no avail. 24V 4amp.

Replaced USB cable with, shorter perhaps a better quality cable, and added ferrite cores.

Disabled USB selective suspend in my laptops Advanced power settings.

Changed other power setting regarding sleep and display.

Upgraded Firmware to latest version OLM3_207.

Adjusted baudrate in lightburn and in my device manager, from 9600 to 115,000.

Added a grounding cable to machine: From Laser head board to X-axis gantry to Y-axis to YRR selector switch to motherboard to the ground wire of an extension cord.

Tried different electrical sources in my home.

Isolated the 5V pin in the USB cable, from the engraver. To prevent mother board from energizing via USB.

Upgraded to Windows 11 for a brief period, downgraded back to windows 10.

Adjusted speed and laser power.

Aside from being recommended a specific USB cable, I currently don’t have any idea where to go from here. I would really like to use LIGHTBURN as my operating software, and I’ve read it is possible. Any suggestions would be very much appreciated.

Appreciate the detail and the troubleshooting thought process.

Some questions for you:

  1. You say LaserGRBL worked without issue. Have you used it extensively since? Can you say for certain you don’t have issue when using that software? A lot of subsequent validations will hinge on this fact so it’s important that you absolutely make sure this is the case.
  2. Can you take some photos of the grounding solution that you added? This would have been my first assumption of what was going on so want to make sure there’s truly nothing going on there.
  3. Are you actively working on the computer continuously while the job is running or do you allow the computer to idle during the job?
  4. What else is connected to the same electrical circuit as the laser?
  5. Do you have this issue with line operations, fill operations, image operations at the same frequency?
  6. When you tested without the laser on, how did you disable the laser?
  7. What firmware version are you currently running?
  8. Have you tried printing from SD card? Does that change behavior?
  9. Do you have access to a UPS or some other method of isolating power?
  10. Do you have access to a bench power supply?
  11. I couldn’t tell from the other Topic, when using WiFi, is the crashing issue the same as the disconnect issue with USB? Do they manifest in the same way?

As a specific recommendation I’d suggest a minimum 650 KVA computer UPS. I have “rural” power and occasionally have had laser jobs crash due to brief power glitches. Your laptop is safe since it basically has a built in UPS. For WiFi connectivity you need to be close (<10 feet) with either your laptop or your WfFi router since the LM3’s WiFi signal strength/reception is minimal. If you can see “all bars” signal strength on your laptop when near the LM3, you should have enough signal for WiFi operation.

Also appreciated good sir.

Update: I am now connected via WI-FI and all of the issues connection I was experiencing while using LB have so far been resolved. I did 27 min run today!

  1. I never had any connection losses while using LASERGRBL via Wi-Fi. Did not use LG via USB.

2.Photos to come. However, I do not think grounding is an issue. As I’ve seen the USB connection drop without the laser moving.

  1. I am not working on the computer, mostly only light burn is running.

  2. I dedicated the entire circuit to the laser alone, by tripping breakers and testing outlets affected.

  3. Losing connection during all laser operation types.

  4. Disabled laser by reducing power to zero. Or by unplugging laser head.

  5. I am now using 205_R29 I believe. Based on the recommendation from brewsters thread. I’m assuming I can upgrade back up to 207_R** (whatever the recommended latest version is on ORTUR firmware repository)

  6. I have not

  7. I do not

  8. I have a variable DC power supply yes

11.WI-FI has been working.

If you see problems return one thing you may want to try is to stay engaged on the computer. I know you’ve disabled power savings mode on USB but there may be other things going idle on the computer. If you’re not actively on the computer you could try a stay awake program to keep the computer fully active.

Drops with no laser movement does imply static is not the issue. That’s curious as the symptoms seem closest to that. That would lead to something else causing a USB short or drop.

Again, if your Wifi fix doesn’t hold, testing with SD card may be a good test to see if the issue with the external connection or something inherent in the device.

Testing with bench supply could similarly be useful.

So at what point do you declare victory on the wifi front? Are you looking to also verify USB functionality or does that become a non-issue if wifi works for you?

Berainlb, I appreciate all the suggestions. I am actually very happy with how my laser is running since I switched to WI-FI. Not a single dropped connection! Several 30 minute runs completed since starting this topic.

Here’s a photo of my grounding set up. Haven’t found any grounding tutorials online so I kinda winged it…




Also, this was my light burn WI-FI set up process for anyone is reading this thread who has limited computer experience like me.

Guys please feel free to correct/add any info to my instructions. Particularly on Step 1. I’m not sure if the latest version on the OLM repository will suffice for this.

Step 1: Install Firmware Version 205_RC29. Download this Firmware version from the Topic I linked to in my first post on this thread. Keep scrolling through you’ll see the download link.

How to install firmware video: How to Upgrade the Firmware of Ortur Laser Master 3 - YouTube

Step 2: With a connection already established to your Device/Laser via USB. Open light burn/Select console tab.

Step 3: In the command bar individually type out, and press enter:

$74=(the SSID on your router) ex. NETGEAR35

$75=(the password on your router, your Wi-Fi password)

$WRS

An IP Address will generate in the console. Copy and paste the IP address.

Step 4: Select the devices tab and manually create a new device. For my Laser Master 3 I selected GRBL. Select Ethernet TPS, copy IP address, and then press ok, select device.

This was my process for connecting to lightburn via WI-FI.

1 Like