Ortur LM2 does not home when powered on and LB will not find it

I recently moved my laser and when i reconnected it, nothing worked. I removed the device from LB and now LB will not find it again. When I turn on the Ortur LM2 the laser moves very slowly at an angle from bottom left corner to top right corner and does not stop when it reaches the end of the track it keeps bumping the frame. I can manually click the home button and it stops moving up but continues to move along the gantry,

Check the connection at the side of the gantry, often coming loose.

Have you tried updating the Ortur firmware?
If you do, then make sure to follow instructions and download the correct firmware…
and LB should find the laser.

Windows machines only!!!

connection is good, i was finally able to get LB to find my device but it seems like nothing is callibrated correctly. it will not go to origin, will not rehome, and when i set a location it travels way to far and bumps teh rails

Firmware update fixed it, thanks guys

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.