Ortur LM2Pro issue with framing

Ok so TL:DR version is the laser was working fine a few weeks ago and now whenever I try to frame a job I get the following error: G-code motion target exceeds machine travel. Machine position safely retained. Alarm may be unlocked. I have the Ortur Z adjust and I have made sure that the X is set at 400 and the Y is set at 380 both in Lightburn and the laser itself. The only thing that has changed is I was using a Surface Pro 7 to run Lightburn and now I have a full sized Dell laptop. I have gone through the other topics after searching for this issue. I have done the $RST=*, I have loaded the latest firmware from Ortur, I don’t believe I have any offsets set either. If I change the start from to “current position” it will frame the job but as soon as I change it back to absolute it gives that error. I’ll post my $# and $$ below.



















































































EEPROM read failed. Reset and restored to default values.


Nice detail in the post.

This actually is an offset. It should not have survived the $RST=* so surprised to see it.

Run this in Console to remove the offset.

G10 L2 P1 X0 Y0

Power cycle for good measure and retest.

Also, your Y dimension should be 400 unless you’ve modified something. You may be losing out on 20mm if you care about that. Should not cause any problem, however, so you’re good there.

Ok, I will try that. I have the Ortur Z height adjuster so it says you have to restrict the Y Axis to 380mm

1 Like

Ok so I did that, reset as advised and it worked to frame the square. Now however its gone back to the same issue and its back to the [G54:-400.000,-400.000,0.000]. Still getting that EEPROM error when I run $#.

Interesting. Curious if you’re having issues with the EEPROM. Can you try flashing or reflashing the latest firmware?

Yea I’ll do that tomorrow after I finish some mother’s day projects. Ive got it working well enough using macros to reset the offset. Appreciate the help!

You don’t happen to have anything in the g-code tab of Device Settings that could be setting the offset do you? Or possibly as part of a Macro?

No I didnt have anything in the g-code tab. The Macro’s I just created and I checked to make sure there wasnt anything in there as well.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.