Ortur lu3-20a not engraving

I have recently upgraded an aufero laser 2 with the lu3-20a. It said it’s compatible but nothing but problems. The fan on the laser runs continuously, but just saw a post how to fix this and I will. More importantly, it will not engrave. I have it focused properly and it did actually engrave until today.

I’ve tried multiple tests at different speeds/power on multiple types of materials. Pine is typically very simple, but it won’t even engrave on pine. I tried normal speeds of 8000/50 and nothing. Slowed it down to 3000/80 and still nothing.

Any thoughts? I’ve actually been trying to return the LU3-20a as don’t think it’s truly compatible for over 20 days, asking 10-15 times how I can do this but Ortur won’t respond. Horrible experience so I’m trying to just deal with it. If anybody knows how to actually get Ortur to stand behind their product, it’d be great too.


Was the original module a 5 watt and now this is a 20w?

Did you upgrade the power supply?

Yes, I upgraded the power supply to support the 20w too.

If you plug the 5W back, does it work?

How are you plugging the OUC board. couple pictures would help please.

Definitely! I am wondering, do you ever see the blue laser light from the 20w head? Does it have a separate PWM control module for the laser?

I just found the problem. There was something with the actual lens and when I changed that out, laser started working properly. Thanks all for the support!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.