ORTUR Master Laser 2 and Homing issues

I just received and assembled my ORTUR2 and I keep of getting the x-axis trying to travel beyond the rail and the arm just goes back and forth in a stuttering manner. This happens every time you turn on the laser or try to home it. You get an error that says it travel beyond d it’s bounds. After the laser kind of resets, not sure what else to call it, but pretty sure is abnormal, the laser doesn’t respond to anything as it has an alarm that prevents it from doing anything. I’ve update the firmware and all. I think my laser came with the updates software but I still fit it anyway. I’ve also made sure I was connected to the power and. It juts USB to the computer, as I saw that comment in here before. I’m at a complete loss. Please help me!

Is there anyone out there that reads these and provides support. Did I just waste $200?

The slamming the end of the rail is probably a limit switch either not present or broken so it doesn’t know its at the end and trudges on… Yes many people read these forums and help often so no need for full panic heh. What firmware are you running?

Thank you so much for responding. What does they switch look like? I don’t recall installing one during assembly. This happens at the right side of the machine as you look at it. I’m tuning the latest firmware OLF_000 and OLF_134. I went through the update process of upgrading it when assembling. I hope I did it all right, but the issue was there before I updated it and after.

After a quick google search for Ortur2 it looks like one is just to the left of the ORTUR name on the machine. There is probably another on the gantry also. it is that small component with 2 wires coming off of it that gets hit by the gantry when it reaches the end of the track. This is also assuming your did indeed come with them of course, not all machines do these days. It also seems like your firmware is GRBL so researching the settings for that and how to change them will help you sort out the issues. If you have no limit switches then make sure the option for homing in the settings is off and manually move the laser to the bottom left before powering on to essentially “home” the machine. Then use “current coordinates” in Lightburn as your starting point I believe.

You will find this video interesting as it demonstrates that the ORTUR Master Laser 2 is compatible with LightBurn.

I currently have an ORTUR Master 15w and have no issue running LightBurn. I’ve ordered an ORTUR Master 2 and I’m awaiting delivery.

‘stuttering manner’ is your speed set too high? The default is 6000 and the maximum you should be running is 1500. - I find 900 to 1200 best for engraving.![Max speed 1500 mm per min

I’m going to try this. The homing send the right side way too far where the other side, then one that has the logo and the two cables that you mentioned, which is the right side stops where it should. I’m getting kind of frustrated with this as I feel like I lost my money so far.

Has anyone found a fix for this? I too just received my Ortur 2. The X Axis hits the limit switch (I can see and hear it), and even when I trigger it manually, the X Axis does not stop. Does this when the unit is turned on, cannot even get to the point I can change speed settings.

Thanks!

I just received my Ortur 2 the other day. I had the same problem. I just went back in and moved the switch forward a little until the laser no longer was hitting the rail. You have to retighten the belt on that side after moving the switch in a little. Hope this is clear. Good luck!!!

Unfortunately I had to deploy and never got a chance to look and fix this issue. I’m afraid that when I get back home I can’t figure this out. Can you please post a video or more clear fix to this issue. I really want to make this machine work when I get back. Please!

I just got my ortur2 and experiencing same problem with x axis there’s an video on YouTube about it saying one of wire terminals was not fully engaged I checked thi and homed wires all were good but when I hooked up to x axis switch only two wise showed continuity when homed and switch depressed sent a message to seller to see if I can get an answer

I had the same issue that some of you are having, where the x-axis wasn’t stopping when hitting the switch. From my end it was a stupid mistake from my end and another mistake that i didn’t check the documents found on the provided by ortur on the link, because there was couple of images regarding connector cable of the x-axis switch, which specified how these cable should be plugged in properly.
My mistake was that i have connected these connector the wrong way. So double check these connectors and hopefully it would resolve your issues as well.

Dude, I was having the same issue as everyone else. The problem is that Lightburn responses DO NOT explain ANYTHING. They only tell you what to do. Their is a process to learning. If you explain, we now know why things need to get done. It sounds gripy, but it’s worth it in hopes Lightburn approaches future responses from a different stand point. All that to say this. Your explanation hit the nail on the head. I disconnected all power supply to my laser, and checked the connectors.
i figured they weren’t made fool proof, and that I may have installed them backward. Well, in doing so, I had to turn the laser over, and discovered that there was a connector that I never new was existent. I plugged that in, and BAM ! ! !!! Machine and software working like a charm. I hope this helps Jairo, the guy that ws getting frustrated and got deployed.