Out of bounds message

I just downloaded 1.2.01 now when I use user origin I get out of bounds message. When I use position tool I get error message
G code margin exceeds machine travel. Machine position safely retained.alarm may be unlocked.(right click devices button to re set)
Tried this but still the same.
When I use current position , I get warning I am out of machine area , I have to press continue to start the burn, then it burns.
Seems there is some issue with the new update, was fine before.
I have ortur master pro 2 (olf170)
I think my firmware is ver 1.1f (esp32).20210403 (opt:VNMSL,15,1024,3)
Laser homes correctly. Cannot see anything obvious in the settings.

This all seemed to happen just after I installed the rotary. I followed all instructions and saved settings for both default and rotary

Is the rotary still enabled? If so, disable the rotary.

Hi, that was the first thing I tried, still the same. I have not changed any settings other than turning off homing and soft limits for rotary settings. I re loaded original settings when I finished with the rotary , now I have this issue.
Regards colin

Can you provide the following:

  1. full screenshot of LightBurn
  2. complete a homing operation and then run these commands in Console and return results:
$I
$#
?


$I
$#.txt (607 Bytes)
txt.txt (100 Bytes)
as requested


[HOME:-397.000,-397.000,0.000:3]

This I believe is the source of your issues.

Or else it could be how you’re using “user origin” as your Start from mode.

Let’s try resetting the offset.

Can you run this command in Console?

$RST=#

Then confirm that the reset took by rerunning:

$#

hi i have done this and home is now showing as zero zero but am still having the problem alarm 2 on or near line 2

Can you take a full screenshot of LightBurn with the Console screen open showing that?

When does ALARM:2 appear? Is it when you attempt something or does it appear as soon as you turn on the laser?

Can you try changing to Absolute Coords to see if that changes behavior?

alarm appears when i try to move laser with the move tool. the home seems to revert back to the *397 *397

used abs coordinates and same thing

only get alarm when i aa
attempt to move the laser with the move tool

Every time I close lightburn and re open it if reverts to -397 x-397 in the home position.
This all happened once I installed the Ortur rotary even though I followed all instructions correctly

It seems that offset is stubbornly holding on.

Try this. You’re running a very old version of the firmware. Try updating to the latest version. When you apply it the offsets should get reset as well as getting you the improvements in the firmware that prevent things like this.

Ortur – Firmware Repository – Ortur

Look for “Ortur Laser Master 2 Pro S1 - OLF 1.7 Series”. Follow the instructions extremely carefully.

phew! that seems to have resolved the issue it’s now responding ok. I a now uneasy about trying into install the rotary again, would that have caused it?

Thanks for all your help

Regards
Colin

Glad that worked.

I don’t think you should let this experience keep you from using your equipment.

If this pops up again use the command below to reset. It should reliably get you back to a working state especially now with the newer firmware. I believe the newer firmware avoids this situation entirely though.

$RST=*