Out of Bounds - Urgent

Hello - I’m a newbie to using Lightburn and my new Monport 80W. I’m coming from CorelDraw and a GCC laser. Everything was upper left corner (no setting Origin, etc.- very easy) .So ALL this is very strange and frustrating to me. I have to run a job ASAP that is 24" long and 12" high. I set the Origin to the upper left (habit) and my work is positioned there on the screen. I keep getting OUT OF BOUNDS no mater where I move it and hit FRAME. Please – I need to get moving on this job ASAP. I probably need very simple to understand steps to correct this because of not knowing Lightburn – sorry. Thank you for your help.

You have to have some kind of origin…

When you setup Lightburn in the ‘Device settings’ where did you set the origin?

Where does your machine home when it boots…?

They need to be the same.

Are you scanning an image or cutting a vector?

The error sounds like it’s coming from Lightburn?

If so you are attempting to lase or move out of the work area. Make sure that’s set properly in the device settings.


1 Like

I am back again with another issue. I have paid 2 people to help me understand this EXTEND SPACE issue and I’m still not understanding. So in my attempt to try it again I think I did screwed something up. The one guy told me I must have had 2 windows of LightBurn open and confused the laser. Now what I have an Origin in my top left corner about an inch and half away from side. So I turn it on and it homes to that Origin. But after that it’s screwed up (and I have evenhit the RESET). I had one window open with the extended space issue. Then I opened another job to see if I could get something produce while I had someone come on and help with that. The graphic was just a simple 12 x10 (acrylic) sign. I had just worked early so I knew I could keep moving. I hit FRAME to make sure and the laser head went extreme left and hit against the side and scraped down along the side and made an odd narrow rectangle.

When I got my help on board - he made me test a couple things including just drawing a simple square in the center which did frame fine. But he finally concluded that having the 2 windows open did something to confuse the controller. I was told to hit RESET - nothing! So to just get some jobs out (which are backing up - and one being a large 23 wide x 18 graphic (which caused this problem) I moved that sign to the extreme right and set the Job origin dot to the upper right (and START FROM: USER ORIGIN) It worked! But the work is being produced in the correct position it originally was - upper right. This is getting my job out but it is still all screwed up for the next one (the big one ). PLUS PLUS PLUS eventhough this is working in reversed by work. I’m suppose to be backwards in acrylic. So I put it right reading and it’s engraving reversed.

Needless to say my laser is screwed up, my work is backing up and I’m ready to have an anxiety attack. I come from 15 years of CorelDraw and a GCC laser that everything was in the upper left corner. No worry of setting points. large items no different than a small one – would engrave fine with no EXTENDED SPACE issue. I am not sure why that went away - it was so easy. I am not a fan at all of this new way. If you can direct me to how I can “imitate” that same way and not screw myself up like this I would greatly appreciate it. I do a lot of large items and keep doing this. Thank you

OOPS - I miswrote one sentence – it should read: . . . . .But the work is being produced in the correct position it originally was - upper LEFT. This is getting my job . . . .

I’m having a hard time following you, what was screwed up?

The Ruida will listen to anyone sending it a UDP packet with the right address, but that isn’t what’s causing you an issue.

Something is wrong in the configuration of the software, hardware or both.

  1. Where does the machine home?
  2. Does the Ruida show 0, 0 in it’s console for x an y after it homes?
  3. Does Lightburn device settings show ‘origin’ in the same corner as its ‘home’?
  4. When you frame, do you frame from the console or Lightburn?
  5. Who is issuing the error Lightburn or the Ruida.?
  6. Who is issuing the ‘extended space’ message?

I don’t think I’ve gotten the ‘extended space’ message.


Hi Jack

Thank you for your response. This is very very strange – for two days I couldn’t get out of this mess. After I received your message I turned on the laser to get the info to respond to you.

Somehow the problem resolved itself. I didn’t do anything different or change anything. I opened the file, that kept getting the extend space message, and it was fine. It framed perfectly and I am now running it. Totally baffled

But it is still reversing the art when it engraves. It shows backwards on the workspace and it puts it right reading when it engraves the acrylic. How do I get it to reverse so I can engrave backwards into the acrylic?

*Also can you please look at the attachment and tell me what is making these vertical striations in the acrylic instead of a nice frosty smooth engraving? I keep changing the LPI setting and thought it worked but it came back. I have a photo but don’t see how to attach.

As I was writing this, that large piece I was referring to… engraved from the bottom up, stopped engraving the last 1/2" of art, and looks like it started to engrave back down? What the heck happened now?

How do I put back the missing half inch? Too late? If this was Corel, I would’ve cropped the area missing and let the laser go back and engrave just that little bit back. I don’t see a crop tool.

Why was it engraving back down??

I have to make 3 more of these. I’ll move the art down but it wasn’t that close to top of the bed - it’s about 2"away. Can I select to engrave from top to bottom to make sure it engraves that on the next ones?

Thank you again


For me to look at something you need to post the photo.

If it works then fails, I’d think a hardware issue. Are you changing to a different file?

If the photo is mirrored, the general cause is the origin of the machine isn’t matching the origin specified in Lightburn.

Where does your machine home (corner) and what is set in Lightburn in it’s device settings?


Hi Jack
Here are photos of the engraving I was referring to. Then I decided I take a shot of my screen showing you all me settings and this new graphic that is only 11 x 12 gave me an EXTENDED space message and I can’t get move this job out – I’m stuck. I have moved it around and changed the JOB position. I haven’t changed the Origin and if I have to. These are the settings I had for another piece that kept giving that message and all of a sudden it worked last night and was a much larger piece (23.5 x 18). This message is very aggravating. I never had to deal with all this in CorelDraw and my old GCC laser. Everything was left top corner and it always had room to engrave any size piece NEVER got any weird message like this. I know you think you are saying it clearly

Sorry – I don’t understand what you are saying for the laser changing the reverse to right reading on acrylic but maybe you see what I need to change in my screen pic

Thank you very much and appreciate your help

Sorry - I didn’t know it the pic doubled in the previous message. Here’s the pic how it stopped a half inch away from completion and started going back down. Crazy? Is there a setting to engrave from top to bottom?

Can you answer my questions from post 5 without the extra editorial? Especially 5 and 6.

It’s confusing to follow you, I know you know where you’re going, but I still have questions from a few posts ago.

We need to keep it simple and deal with one issue at a time.

Yes you can tell it to go top down. It’s in the optimizing I believe. If you ventilation is at the rear you want to engrave from front to back (where it will be drawn out.). Did you get any kind of error when this occurred?

Are you manually setting the ‘origin’ on the Ruida console.?


I apologize for any confusion. I was trying to explain it the best I could. And didn’t answer your questions because I was confused how to, plus didn’t know where to find those answers. I gave up and got a Lightburn session. He got me straightened out and told me what should and shouldn’t be selected. So I am back on track and working.

BUT the only thing that he really couldn’t answer was those vertical striation bands and thought it might be the LPI which he changed. I haven’t had to run anything to see if those occur again but if they do is there any other setting to help get rid of those?

Thank you very much for your help and sorry I was confusing.

When people post we hope that they are doing their best. We don’t learn by osmosis, especially via terminals… if you don’t understand the question or how to get it, just ask. There is no ‘dumb guy’ (or girl) label that pops up with your name…

A large part of this is learning the jargon, another big part is patience. Sometimes you just need to walk away… you brain will work on it in the ‘background’…

When you debug something, you can only deal with a single item at a time and even that can be confusing. Sometimes you need help in determining what part is the most likely ‘suspect’ or is it all of them… that’s where forums are of assistance.

Most of the time this stuff isn’t configured correctly. It has so many options that you get lost.

I though these were bad… I have a cardiac defibrillator, I asked the tech how many adjustments it had as he was poking stuff into the computer. Just a little over 60,000 he advised… now I don’t want anyone to change any of them :crazy_face:

Don’t worry or lose sleep over this stuff, just ask…

Glad you got it up, sorry we couldn’t have been of more help on line…

Take care, have fun


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.