Overburn of image edges with gCode controller and diode laser

It’s been a while since I posted - my previous version of Lightburn was working great!
I upgraded to the latest version over the holidays (0.9.20), and now I’m getting overburn on the edges when trying to make an image etch. I also moved to a new(er) computer.

I checked the settings, and I’m overscanning at least 2.5% (I’ve gone up to 5%), but get the same results.
See the photo I attached of two examples of Greyscale and Jarvis scanning.

I also have screen shots of the device and machine settings.

Some preliminary info:

  • I’ve tried Jarvis and greyscale - both overburn the edges
  • Overscanning is on
  • I “believe” I’ve set all the device settings to be the same as the old computer
  • laser and controller are the same and are gCode-based
  • Laser is a diode laser

Any help or pointers would be great! I’m scratching my head here, and have burned many panels trying to figure this one out.

Typical image settings.


The machine you’re using - is it using GRBL or another supported firmware?

Older versions of GRBL, and many other non-GRBL controllers, do not have “laser mode”, meaning they think you’re using a rotary spindle, and every time the power value changes (or the cutting mode) they pause.

The ‘Use G0 moves for overscan’ setting you have enabled might be the culprit here, because I don’t see evidence of pausing anywhere but the edges, which suggests that your machine is pausing when it encounters the first G1 command after a G0, but not on subsequent G1 commands.

Also, your “Fast Whitespace” speed is slower than your engraving speed, so that’s not saving you any time.

The machine I’m using uses GRBL. I think it’s a newer version, but I’m not sure how to check that.
disabling the G0 for overscan did the trick! Thanks. I must not have moved that setting over right from the old computer.

Thanks for noticing the fast whitespace speed, too.

Until my next issue arises, cheers!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.