Overscanning dosen't work

Hello guys!
I have problems with overscanning. For test, overscanning is set on 50%, and it can be clearly seen that when the laser came on the spot where it must turn on, it stops, turn on and then continues, like overscanning isn’t turn on.
I don’t know what controller it is so here is the picture.


Here are a firmware settings:
$0=10 (step pulse, usec)
$1=250 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=7 (dir port invert mask:00000111)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.010 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=100.000 (x, step/mm)
$101=100.000 (y, step/mm)
$102=800.000 (z, step/mm)
$110=5000.000 (x max rate, mm/min)
$111=5000.000 (y max rate, mm/min)
$112=800.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=200.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

Kind regards,
Mario

Your controller is basically an Arduino with a pair of stepper motor shields on it, and it appears to be running a very old version of GRBL, that does not have laser mode. This is why the machine pauses when the power level changes - it thinks you are using a CNC spindle (rotating cutting tool) and the RPM has changed, so it’s pausing to let the spindle get to the correct speed.

If you have GRBL 1.1f or later, you can enable laser mode by setting the $32 parameter to 1. This tells the controller that the tool changes power instantly, and no pause is required.

The only real option to fix it is to flash the controller with the newer firmware. Double check that what you have isn’t 0.8 or older, as those have a different pin configuration and might not be compatible with the newer version.

Thank you!
Controller is in the process of updating, some errors pops out so I’m trying to fixing it. If it dosen’t work out, plan is buying a new Eleksmaker controller.
Original 3.3W laser was changed with 30W, do you think that 30w modul could make some problems?

There’s no such thing as a 30w diode - you likely have one that requires 30w of INPUT power, which is not remotely the same thing as 30w of optical output. That said, as long as your power supply can provide 30w of power, it should be ok. If you are using that module without the ability to adjust the power based on velocity, you would get a lot of scorching.

Great! Thank you! :slight_smile: