Overscanning - Laserhead moves beyond bounds - Bug?

This happaned to me twice by accident. did not try to reproduce this yet…
I think the Overscan extra travel move is not factored in and if the scanning is close to my laser’s workspace physical borders the head goes beyond that causing the motors to stall and lose steps. this happened to me once few months back. it happaned to me again yesterday. lightburn does not throws warnning that the extra move goes beyong either limit switchs or end of travel to the other extreams

Does your hardware actually ‘collide’ with something physical to cause it to loose steps?

I’d be surprised if Lightburn didn’t take this into account.

Does your controller have ‘soft limits’ enabled?


Everything works like a charm till i found out this issue. seems like when i start a fill area which starts like +5mm on X and overscanning is set to like 5% which for a wide scan it comes down to like 8mm overshoots - the laserhead goes beyond X0 to the negative side. i will try to reproduce this issue tomorrow.

Overscan is based on the speed that axis is running.


LightBurn has to command the travel of the laser head to handle overscan. The coordinates are no different than if an object was placed there, the difference being the laser doesn’t fire in those areas. I see no reason why overscan wouldn’t follow normal workspace limits and warnings.


Are you perhaps using current position or user origin for your coordinate system? Try with Absolute Coords.

Hello there,
I always use Absolute Coords.
Shortly i will try to reproduce this and will report back.


Yes, You are right. my mistake. i am trying now with speed which overshoorts my design by 10mm. I placed my design at +5mm on X. will soon share my findings.

I think I’m onto something here. I need you guys to double check me cause i might be doing something “illegal” and I’m drunk.

check out this screenshot. if i chose the upper black squares which are a group - lightburn pops up this warning message. the left black square is 9mm from X0 which is less than 10mm needed for clearance.

But - if i select the bottom design which includes the same squares at the same place which is 1mm closer than my 10mm overshoot (9mm from X0) AND has this surrounding red cut - Lightburn does not say anything and continues like nothing is wrong and nothing is outside it’s defined bounds.

When these two layers are select - no warning

Fill (Black layer) plays before red layer.
If Red layer plays before black - i get the warning.

Again, I might be missing something here.
Please check me :slight_smile:

A few scenarios to check given that:

  1. What happens if you select all the objects?
  2. What happens if you put the red rectangle over the top 2 rectangles?

Can you check the previews of the various scenarios? Do the overscan areas change?

Separate question, are you certain that your workspace dimensions reflect your actual machine dimensions? Can you manually jog through the full range of its motion?

Same thing.
If Red layer plays before black - No warning.
If Black layers plays before red - Warning pops up.


Black before red (No warning)

Red before black (Warning pops up)

So you’re saying the presence of the red rectangle prevents the warning message?

I just tested this and can confirm the behavior. LightBurn doesn’t warn on this which feels like a bug.

Do you have soft limits enabled on your controller? That should prevent any crashes that would get by LightBurn.

Correct and this depends on which layer plays first.


Apparently not.
I will check how to enable these in Smoothieware but we both agree that lightburn should prevent this scenario from happening in the first place.


This seems odd…

Screenshot from 2021-12-18 11-08-55

Screenshot from 2021-12-18 11-09-13

Shows different ‘transversal moves’ when it starts. Like the origin is not the same…?

Maybe I missed it, but what do you run for ‘Start From’ and ‘Job Origin’?


One is showing preview when black layer plays before the red,
The second one shows when red layer plays before the black.
Not sure how the start from and job origin got to do with why lightburn does not warn the user that design is out of bounds. for the record i start from left and set for absolute coords.

When I have a puzzle, I look everywhere for anything that doesn’t ‘look’ right.

Assuming the same ‘start from’ it’s not what I would be expecting.

Just pointing out that ‘something’ is different… No matter what the object, ‘start from’ should be ‘start from’…


No worries mate. You are right and I do the same.
This looks like an elusive bug and it took me two years to step on it by accident :slight_smile: Lightburn should know its bounds at all times and circumstances.


Hopefully we can get a comment from the LightBurn folks once the weekend is up. I suspect this is related to the same grouping and framing issues that exist since the out of bounds check is only failing with multiple objects selected.

Looks like we’ll have to hang in there until @LightBurn drops the truth on us :slight_smile:

I think you tripped over it, lets hope Oz can step on it if it is a bug…


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.