Pannign around the screen issues

I am unable to pan around the screen by holding down the mouse wheel and moving the mouse. I can if I hold the space bar and left click then move the mouse. When this started it seemed to go back to default settings as my windows were back to the default settings. Is there something I can do to get the panning back by holding the mouse wheel? This was is much more user friendly for me.

I just tested, and learned about, using the scroll wheel that way. LB v1.4.00

  • Roll scroll wheel zooms in and out.
  • Click (hold depressed) the scroll wheel, and you can drag the workspace around.

Works for me, thanks for the info!!!

1 Like

It has always worked for me in Win 10 and Win 7.
Are you using Mac or Windows?

Please check to see if a Hotkey was unintentionally assigned to Pan / Drag View.

In the hot keys menu under the main menu, pan/Drag view has nothing to the right of it. Is this the correct location? Just as an FYI it has always worked in the past this was something that just recently started, additionally my windows are giving me issues as well. I have them on the right of the screen I used to have 2 sets one above the other now I only can get one set. These issues are only on my laptop, running windows 10

I would attempt to import prefs from when things were working well for you. It should clear up the window behavior and it might set the pan/drag back.

Start LightBurn without a project.

In LightBurn, click File, then click Export Prefs and select a filename that will be easy to remember if you need to revert back.

Then click File, then click Load Prefs Backup. You should be able to find an option there that will contain all of your previous preferences.

Let me know if it works.

That did work with the window issues but no luck with the pan/drag. I miss typed above I am running windows 11 if that makes a difference

There aren’t a lot of Windows 11 devices here or in our customer base. I’m sure someone will have one for testing.

This is a tricky one. I’d like to confirm another piece of information if I can. Middle mouse / wheel click is on it’s own microswitch. If I apply middle mouse click in my Brave Browser or Slack I get a round circle with up-down arrows. I get a 4-arrow pan/move in Firefox. Do you get the same?

I run W11 and this is definitely not an issue inherent to W11 as I can do middle-mouse-button panning without issue.

1 Like

Is there a way to turn middle mouse click off in all apps? (franticly googling)

I’m not aware of anything like that in stock Windows. I think it’s first worth confirming that this isn’t a hardware issue.

1 Like

The odd thing is that it did work and one day it no longer did. Laser engraving is the only thing that laptop is used for so I know it wasn’t an issue caused by another program.

I’d suggest testing the mouse on another computer to confirm function. Or try the middle button on a known working application. That will reduce the potential variables to consider.

1 Like

So I did try another mouse prior to posting, but after I saw the last reply I thought about it and tried a 3rd mouse and that one worked. The first one I tried was the same brand as the first so thinking may be a bug with the compatibality

Strange! I too had this happen yesterday when I did a Reset to Default Layout on the laptop that feeds the Laser. It changed to all tabs all across the bottom of the control windows. This laptop remained with the windows parked vertically when I did the “Restore to…” Both are Win10 Dell laptop machines, i7 and i3, and there have been recent MS patches.

Thumbwheel still working as expected.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.