Parking head after cut or etch

Greetings Lightburn users.
I’m experiencing an end of cut issue which will eventually crash the head if it’s not fixed.
The current task is etching on driftwood.
Because of the thickness of the wood the “Z” axis is dropped before starting the cut.
After the etch the “Z” axis moves back to zero position first … before “X & Y” axis begins to move to park position.
The finish sequence needs to change to “park “X & Y” axis” first then move “Z” axis to zero.
I see no option to change the sequence in the Lightburn user interface.
Browsing the LightBurn perfs folder reveals no obvious answer either.
The machine is running Smoothieboard with Cohesion 3D firmware.
Looking over the Smoothieboard config file is not revealing the “finish of cut” sequence.

Anybody have ideas where to look, how to make the change ?

Thanks kindly for your input.

There may be an order some where, but that’s not how cnc machines generally work.

The general rule is move the Z ‘tool’ up out of the way of anything on the table then X & Y can be moved with ‘hitting things’.

I don’t know if the source is available, but I changed grbl to bypass my Z axes when I had a problem I had to work on.

:smile_cat:

Being a laser cutter the Z axis is the bed movement rather than the cutting tool.
The machine is junk / spare parts build using a first generation Smoothieboard and Cohesion 3D firmware.
Being a scratch build there is likely something overlooked.
Processing thin materials the machine has been running fine since April last year.
This issue came to bare due to the thickness of the material … beach salvaged driftwood.
THX

What coordinate system are you using in Start From? Different choices behave differently for what happens at the end of a job.

Have you looked at disabling “Return to finish position” in Edit->Device Settings? I don’t know if this will prevent Z-axis movement but I suspect it might.

It’s all relative… Move the head up or move the table down, same results… space between the Z tool and the work piece increases.

:smile_cat:

Michael over in the the Makers forum suggested to look at the gcode which solved the problem.

Here are the results.


Thanks for the gcode inspection suggestion.
So here’s the last couple lines in a simple circle path.
It is obvious what’s going on.
The software generates a return to “Z” zero position after the run and before it posts a return to user defined position.
When the “Z” command is cut then moved to “return to user-defined finish pos” the machine does what is needed.
Software version is LightBurn 0.9.24
Is there an updated version the corrects this bug ?
Otherwise I’ll have to remember to edit the code when doing thick material.

Thanks so much for your guidance.

G1X73.82Y42.58
G1X73.28Y42.97
G0Z0
M107
G1S0
M5
G90
; return to user-defined finish pos
G0 X500 Y300
M2

You must be using absolute Z moves - I would likely make more sense to use relative Z moves, and just move the Z bed lower yourself before running thick material, otherwise the software will return everything to zero at the end.

You can set this in Edit > Device Settings in the top right - enable ‘Relative Z moves only’ and then if you manually adjust the Z before you start (or use the Z-jog buttons in the move window) LightBurn will only make relative moves from wherever your Z is when it starts, if the layers specify them, otherwise it’ll leave the Z alone.

1 Like

Thanks Oz …
You are correct, the “Relative Z moves” was toggled off.
I have been lowering the bed as needed for the material thickness.
Then matching the same bed height number in the layer settings to keep the bed from moving.
A quick test confirms toggling “Relative Z moves” to on is the solution.

:v:

1 Like

Oz … if I still have your ear …

I could see how adding “Z axis” to the user-defined finish position would be helpful feature.
Yes … I understand this would not have solve my issue with “Relative moves only” toggle button.

THX again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.