Pass Through mode

I was told that when using a certain script for engraving that I should use pass through mode in LB. But, I should turn it off, set my line interval to my dpi, and then re-enable pass through mode. To me it seems that anything that is greyed out in pass through mode would be ignored and there would be no reason to change this setting. Am I correct in my thinking?

Changing the line interval will force a re-sample of the already dithered image in LightBurn. The script you mention is dithering for you as part of the script. LightBurn tries to resample everything to the final size for quality, but resampling a dithered image produces artifacts, and pass-through turns off all the resampling.

1 Like

Pass through means “don’t touch”, ;as in, LightBurn should emit one command per pixel in the original image, without further processing. If you change the DPI setting, normally LightBurn resamples the image to match that setting, as Rick mentioned.

Sean’s script does the dithering for you as its final step, meaning that resampling would cause moire artifacts. If you need to adjust the DPI, do it in PSP before running the script, or remove the final dithering step in the script, which would let you resize and dither in LightBurn.

1 Like

But, back to my question, does changing the line interval setting in Lightburn actually do anything if pass through is enabled? I think you are trying to say no… correct?
I do know the process and have been using it. Sean recently posted this to me -
“You simply disable pass thru type in your dpi and then re enable.”
Does this do anything to the image?

When pass-through is enabled, the DPI setting is automatically computed based on the size of the image. Let’s say you started with a 500DPI image when it was imported, and the size was 5" square. If you resized it to 10", you still have the same number of pixels, so the DPI is now 250. Any DPI or interval setting applied to a pass-through image is completely ignored, and Sean is mistaken.

It would be really nice if he’d provide a version of the script that omits the dithering step - it would allow you to do much more with the result in LightBurn, though to be honest, it’s not really necessary at all.

Try this:

  • Import an image, and select it
  • In the Shape Properties window, set the “Gamma” value to 0.65
  • You may also wish to adjust Brightness and Contrast, depending on the image, but leave that for now
  • Set the DPI to 254, speed to 120mm/sec, and choose Jarvis dither
  • If you’re engraving black paint off a white surface, be sure to click Negative Image

Run that, and compare the output with what you get from Da Script.

1 Like

Ok so the answer to my question is ‘Yes’ it does affect the image if I turn pass through off, change the setting, and then turn it back on. I figured it would just negate any changes when turned on again but it sounds like it would be detrimental instead. Good to know. I will try out your suggestion Oz… thanks guys

No, no, … It doesn’t. If you turn off pass through, then change the DPI, then burn it, it would be your chosen DPI. As soon as you turn pass through back on, it’s ignoring that DPI setting again, and computing it internally instead. It’ll remember the setting, but it’s not using it at all as long as pass-through is enabled.

1 Like

So it made no permanent changes to the image during the period that it was disabled and setting changed… all undone when enabled again?

Correct. You changed some settings, and those settings are remembered, but as soon as you turn pass-through back on, they’re ignored again.

Gotcha. Thanks again

I brought an image into Lightburn with pass through enabled. I then disabled pass through and changed the dpi. Next I enabled pass through again and clicked ok. The Interval (mm) changes.

Yes, correct, it does. Interval and DPI are two different ways to set the same number, and are linked. Pass through doesn’t let you change either of them because, again, it would require resampling the image. If you don’t believe me, make a tiny dithered image, like 20 x 20 pixels, then bring it into LightBurn, adjust as much as you want, and preview. Then try the same thing with pass-through enabled.

I guess my point here is that all the changes that were made are not undone when pass through mode is enabled again as discussed before. Does the Interval (mm) change of value have an effect on the image? I assume thisis the same thing as scan gap that I have heard about. I am new at this and just trying to figure out what is going on! :grinning:

Interval / DPI settings are ignored when you have pass through enabled. You can set them however you like, and LightBurn will remember the settings, but ignore them completely if pass through is enabled.

Jack, Oz did write the program, so what he’s saying is rather correct, but I’ve found I like to bring a picture in, then turn OFF pass through, so L’b pickes up the correct scan gap or advance or DPI from the original, and that sits in the box, then I turn pass through ON, and although the figure is ignored, and greyed out, it LOOKS right sitting there, being the right figure.

I get the heebeegeebees if the figure in there - greyed out or not- is not the right one, so I likie it to look right, even though it is ignored! (Maybe I’d old fashioned!)

Hope that helps.

But as Oz says above a few posts, try the whole thing, minus the script- just bringing the correctly sized, and gamma-edited greyscale JPG directlty into L’b and run Jervis dither. You might be pleasently surprised!

1 Like

Stewey, Sure, I get it… it did throw me off though because when pass through is enabled those things are grayed out in the cut settings window but in the main cut window they are not. You can still change the interval in the main cut window which in turn changes the greyed out dpi in the cut settings window. You don’t have to turn pass through off to change the interval setting. But I do understand now that it doesn’t matter.

I have a bit of a problem as well. I’m using Sean’s script as many other people and today I was working on one long piece (23x65 cm) so I turned it sideways. I unchecked Pass-through, set speed and power, check PT again and turned on Preview and here comes the kicker. It only processed a part of the image. I turned it back upright and now it shows whole image. Turned 90 degree again, only shows part again. It also changes times from 15 minutes for sideways to 90 for upright position. I found a workaround by turning image sideways in Paintshop pro and now it shows same image laying sideways as a whole. But I was wondering why would there be this kind of problem in Lightburn.

‘Pass-Through’ is really intended for things that are dithered outside of LightBurn, where resizing the image would cause unwanted aliasing artifacts. If you are going to dither the image outside LightBurn, do all sizing, scaling and rotation outside of LightBurn as well for now. Then use Pass-Through and LightBurn will will “pass” your image “through” without any further image prep.

This being said, the 0.9.02 release should let you rotate 90 even with pass-through, but it has to be exactly 90 / 180 / 270.

1 Like

Ah. Thank you. I didn’t think rotating it would count.

Are you working with 0.9.02 and this is not working for you?