Pass through still enables the image mode?

Hi, I selected pass through in the layers setting for an image, but the end result almost seemed like a threshold setting. I then selected the image and saw the default was set at Threshold for image mode. Do I have to adjust the image mode for each image even if I selected pass through in the layer menu? I don’t think I had to do that before. I suspect this is threshold due to the clear black and white sections. Some “Gray” sections in the original image did not burn the paint at all, making me suspect it was omitted by the image mode. The image was processed through Imagr and looks ok in the Lightburn display.

I checked the layer menu after the burn and it was set at pass through.

So even if I click Grayscale and set the image to gray scale, the layer menu still shows Threshold as the default for passthrough. If I change it to gray scale in the layer menu and click passthrough, it changes to threshold as the default greyed out option. No idea if that has any effect or is just the default menu option.

Pass through does not currently support grayscale, nor should it be necessary for grayscale.

It’s intended use is for files that have been dithered outside of LightBurn, where resizing the image in any way will produce horrible moiré artifacts, so it forces the system to send each pixel exactly as it is in the source image.

So if I use IMAGR and skip the color inversion, then use pass through, it should come out close to the IMAGR image right? Not as threshold.

I may have been mistaken about what pass through does, but i thought it turned off the image modifications in LightBurn such as dither, grayscale, or threshold in favor of the pre-processed image.

Pass through quite simply means, “pass this straight through to the controller”, however, it is intended for use only with pre-dithered images, because those are the ones that actually suffer if resizing is done.

If the image is a photo, or other “continuous” image instead of being made of discrete dots, resizing / resampling doesn’t produce significant artifacts, so I didn’t do all the extra work required to support pass through for grayscale images.

If you output this from Imag-R, it is very likely already dithered. If you zoom in, does it look like just dots?

No dots. Like I mentioned, this looked like Threshold. You can see how the greys are omitted in the engraving. The black patches are practically untouched and smooth, which made me suspect threshold (also the major contrasts). It cut all the way down to the tile right next to absolutely unlasered “white space” black on top. No transistions. Strange thing is I never used threshold for any of my engravings so this was a weird occurrence. This seems to be a one off thing as I could engrave other things afterwards with the appropriate output.

It is absolutely using threshold - that mode is forced when using ‘Pass-through’. If you want grayscale, you need to disable the pass-through option and set the image mode to Grayscale.