Paths Progressively Off After Small Rapid Movements

I’m trying to cut this design:

I’ve noticed that the holes seem to drift over time several mm when running at 100mm/s. I’ve taken the same file and speeds into RDWorks and the issue seems like it might be present, but its very much reduced (0.10mm?) at the same speeds. I tried a backlash test file in both Lightburn and RDWorks and it looks fine at 50/100/150 mm/s, so I’m not sure what the issue is. Backlash optim repay was not checked in RDWorks. I don’t think it’s circle dependent, when I was making some tokens back in October I noticed my cuts were walking in relation to my engraving, notice the text in relation to the outer perimeter. Any suggestions?

RD Works Backlash Test

RD Works Chain

Lightburn Backlash

Lightburn Chain

Here’s the dice, notice the text compared to the outline

Edit -> Machine Settings. find the Engraving Acceleration setting and nudge it down about 20% and see if that helps.

Both engrave and cut acceleration (top pictures were all vector)?
I’ll give that a go tonight and report back.

Yeah, sorry. Both cut and engraving acceleration.

Did not appear to affect anything, possibly even worse, the rectangle boundary by the shifted holes at the top is about 4.5mm away and on the last run it was about 3.5mm. Also I did this test twice as the first time I had the holes facing the wrong way and was off the material, and it cut the boundary over the top of the pattern. It’s weird, if the steps/mm were wrong you think it would skew but the skew would be the same, it seems to be losing something from left to right that its not getting back.
Settings: yellow I changed by 80%

Cut test with these settings, alignment matches the alignment in the first post. The red dots are marker, the laser did these holes as it was doing the up and down pattern. They look well aligned. The other holes it came back and did after mostly finishing all the up and down patterns (minus the last two lines)

First cut test, off the page and rotated 180 degrees from the first post

I’ve also tried this by having all the inner circles on their own layer and doing them first, had the same shifted results. I did that on foam before I realized that everything was off and I started this troubleshooting.

Any other thoughts to try?

Check your rails to make sure you don’t have a sticky spot, or loose bearings in a slide carriage or something. Does it seem to be position sensitive? If you run a job like the above in different locations on the bed, does the result get better or worse?

Hi Jesse
This shifting is a loosing steps of your stepper motors, maybe due to exceed the limits of your system (high velocity) or wrong driver configuration (current to the motors).
The easy way, low velocities. In my machine, 100 mm/s to cut or marking lines is a excesive velocity, maybe 60 mm/s as a limit
The driver configuration is not as easy as give higher currents to the stepper motors. Don´t do in that way

@LightBurn I will try this and report back.

@Otromar The weird thing is RDWorks does not have the problem with the same file and speeds. And I think I saw this when I was cutting wood at 8mm/s, see the box of triangle tokens and the location of the “m” in relation to the cut edge in the two bottom right pieces.

RDWorks likely plans the path in a different order, and that order will make a difference. With tiny cuts like these you’re likely hitting resonance in your motion system, and that will make you skip. Slowing down, even a little, might make all the difference.

Read this other thread on exactly the same topic, and watch the video I posted partway down the thread:

Ah, ok Jesse, but, the M is engraved, and then again, maybe, you are engraving too fast. I have this issues too (engrave, then cut, and get misaligned part). I slow the engrave velocity or better, group it engrave + cut for each piece.
I explain better, in a matrix of … X repetitive pieces, normally first engrave then cut it all, but, in this cases, i load in rdworks the initial piece to repeat (two layers, engrave+cut), group it and then send it to the laser. The job engrave it and cut it piece by piece. Maybe the job time is larger but you get a correct work. I figured out that for small distances something like 250 or 300 mm/s (engrave vel) result in minor acel/deacel times. In a large distance to engrave, i used to do 400 mm/s. And the final time isnt too much different than the firs manner

@Otromar That is true, the engrave was done on a different layer at a different speed so who’s to say which one might have shifted there. It’s been awhile since I did that job, but the speed would have been between 100-150 mm/s for the engrave, I don’t go faster than that or I lose fine detail.

@LightBurn Yes the pathing is differing. I think both of them had a fair bit of jumping back and forth with the circles. Maybe when I do my testing in different parts of the bed I’ll take a video, I have a camera above the laser.

Sorry for being off topic, but why is it you can see those machine settings? My menu is way more limited (smoothieware, cohesion 3d)

Smoothieware stores machine settings in a text file on the SD card, so it’s not nearly as easy to read / change it from software. Power off the controller, put the SD card in your PC, open the config.txt file with a text editor, make your changes, save it, put the SD card back in the controller and power it up.

You were right, paths are different, when I forced different paths in RD Works I got the same issue. Even down to 25mm/s I had the issue. Accidentally I found if I run the same program twice I can see the shift obviously. I did this with my own test pattern and the shift is only in the X direction.

I tried turning down my acceleration to 2000mm/s^2 which is the same as the Y and still had the issue with no noticeable difference. When I measure my bounding boxes the size looks right so not a steps/mm thing I’m thinking? Thoughts and next steps? For reference here are my settings

I would try dropping Min Acceleration down to 150 to 200, and Idle Accel down to about 1500 to see if that improves anything. Check the mechanical parts over too - see if you have any sticky or dirty spots on the rails, bearings, belts, etc. Even something small can cause trouble.

Sorry, got busy with some trips.

I turned down my min accel to 150, changed my max accel everywhere to 1500. Results seem unchanged. Left is the settings before and right is the lowered accel. For the test I ran the test pattern complete once, then ran it again ending just before the little boxes, then ran it a third time stopping just before the boxes. The pattern moves to the left. It moves the most after a full run and less after a run with just the zig zag lines and outer box.

Just to confirm its getting off I tried a test where I reset the controller, ran the pattern full, reset the controller (it homes upon reset) and ran it full, and it lined up perfectly upon itself.

Next steps? I should also mention I cleaned off the X rail, added fresh lithium grease, and checked for belt tightness and backlash, it didn’t seem to be able to move back and forth while powered by hand (steppers holding).