Pattern Not Found

After running RDworks for many years im really enjoying Lightburn and am blown away by its usefulness. After waiting a while I finally ordered a LightBurn branded camera from the site about two weeks ago. I have tried many times, but still, am having difficulty setting the camera up.

My machine is a Boss 1630 With a Ruida controller. I have a Lightburn 140 Camera. I’m Running the latest version of lightburn (0.9.02) on a Toshiba laptop with the most up to date Win10.

I mounted and followed the setup instructions and videos for calibrating the camera. My laptop recognized the camera as soon as I plugged it in and set up it up. I checked the installation through device manager and verified it had the most up to date driver. I opened LightBurn and started the Lens calibration wizard, selected the LightBurn Camera and placed the printed circle pattern (mounted on board) as the example shows. This is the point I cannot move forward on. Whatever I try I cannot get a score and only receive the “Pattern Not found-try again” message.

After reading many posts on the forum I have tried several things including
-Rebooting computer
-Deleting Camera driver and reinstalling
-Downloading usbcam driver wizard (straight from manuf site). When the wizard is run it does not recognize the camera. I ran the 2 exe files (innos folder) as stated in one blog and restarted the system several times with no luck
-Attempted the same procedures with another Dell laptop. No luck
-varied the focus of the lens
-covered my laser bed with white cardboard
-repositioned camera multiple times.

I hope I’m missing something basic and would really appreciate the help so I can start using the camera function of the software
I appreciate any input and thank you in advance


To me, that looks like two things might be happening:

  1. Your lighting is quite uneven, and that’s going to make it harder for the software to find the circles pattern in the card.

  2. Check the focus of the camera. If you go back to the main “Camera Control” window, drag it out of the side dock, then drag it larger. If the image in that window is blurry, you’ll need to adjust the focus of the camera lens. There’s usually a small dot of glue holding the lens that can be removed carefully with a hobby knife - it might be clear, or black. Then, holding the base of the lens assembly (the square that’s mounted to the board) twist the lens slowly, in small increments, until as much of the image is in focus as possible.

Check both of these things, then try again.

Thank you for the quick reply.
I tried the two things you suggested

  1. I broke the seal on the camera lens focus adjustment and managed to get it a little more in focus as it was set.
  2. i added a high power led lamp to see if the extra light would help the software find the circles.

While both improved the image quality coming into the LightBurn application the wizard is still showing the same message " No Pattern Found"

Thank you for the help, can you advise on further troubleshooting


The only other thing I can think of is that your pattern is very close to one edge of the wood - It needs a border of white around it on all sides for the pattern detection to work well. Try centering it on the board you’ve taped it to.

After a couple of more searching on the forum, i came across a suggestion to print out the pattern in landscape form. I printed it out and ran the test again and it worked. I do think you were right about the border of white around the pattern. The landscape print gave me that border.

Thank you for your time and help

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.