Pause does not exist on version 09.17

with the update to 0.9.17 lightburn as soon as you press the pause button and then reactivate it, the laser head moves as if it were to resume engraving but the laser is not active

1 Like

I will investigate this today. We have a couple of other small issues to be released in a patch, so I will see if I can solve this quickly. What kind of laser do you have?

ortur laser master 2 15w

ciao, stesso problema con ortur master 2 20w.

@OrturTech - This appears to be a bug in Ortur firmware.

When I pause other GRBL machines using ! and resume with ~ there is a message that says “restoring spindle” and the laser resumes firing. On the Ortur, the ‘restoring spindle’ message is shown, but the laser never turns on again.

!                         ; this is the pause command
~                         ; and this is the resume
[MSG:Restoring spindle]   ; GRBL tells me the spindle is back on

It looks like the reason this worked before is that I was adding other commands to the stream to turn the laser back on, but that would not always be correct, because I don’t know where in the serial buffer the last laser commands are.

Can you ask the firmware engineers to look into this? When the ~ (resume) command is sent, the laser should be re-enabled if it was on before the ! (pause) command.

The bug is identified and they are working on it, i will relay though

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.