Pi burner 3.0 not spinning while rastering issue

Hello LB community, I fired up my radial machine for the first time and everything set up to the best of my knowledge according to pi burns video. When it rasters or vector cuts on the cup, it fails to spin. Although it does spin when I turn the machine on as it tries to home. I can also manually spin it on my Ruida controller. I have a fl-1390 machine. What am I missing here, something in the settings? Thank you for any help. I have 32 tumblers waiting to get bumped out!
Together,
Aaron

Does the rotary rotate the driving wheel one turn and back when you press the ‘test’ button?


You have your steps/rotation set properly?

:smile_cat:

I just tested it and the head moves over in the Y position an inch and moves back after about 5 seconds. That’s all that happens.

Lmk if you want to talk over the phone, I’ll venmo you some coffee! I can let you know my company and I don’t think we’ll get denounced. If not help here is good to. I told my customer these would be done by Friday night lol This shouldn’t be this hard lol

Together,
Aaron

Send a screenshot of the roller setup window.

Here’s the manual for the PiBurn 3.0. Go to page 11 where the setup lives. It has a few examples on steps per rotation and roller diameter.

http://piburn.info/manual/PiBurn_Rotary_Manual_V3.pdf

The setup is realtively easy…

Check your motor drivers for the steps/rotation…

Mine are set for 2000 steps/rotation… that is the motor…

Now apply the ratio between the motor and drive wheel…

2000 x 2.5 = 5000 steps/rotation in the Lightburn gui.

The wheel size is like 63mm, I think mine turned out to be 62…

rotary-controller-settings

Is this what you’ve done?

:smile_cat:

Hi yes I’ve been trying to do that but I can’t figure out how you came up with 2000? Sorry if I am missing the obvious.


Thank you so much for your help!

I see the pulse rate on number seven (on) and it’s at 3200 but don’t understand the two and three (on) and how that bracket applies?

If I go by 7 and 8 x 2.5 it’s 8000.

His stepper driver is different than yours.

Your driver looks to be 3200. So 3200x2.5=8000 steps per rotation to start.
What is your roller diameter set to? Should be 63 or 62 per the manual.

Also make sure it’s set to a roller rotary.

@micrololin is correct, it’s the 3200 x 2.5 = 8000.

Set your gui to that and the driving wheel to that specified in the manual.

If there is any fudge factor, it’s the wheel diameter… every thing up to that point is digital…

The other switches on the driver limit current to the motors… Mine ran real hot and I found the factory had set them to twice the rated motor current… I corrected the switches and they run cool now…

Good luck

:smile_cat:

Great news, after 2 days of problem solving with you guys I got it to work. You guys are just great and I’m so thankful for your help. The issue was a physical toggle switch inside my machine. My first mock up turned out perfect. 17 left to do! I’m timing myself, I’m so happy to be doing this first job. Pardon their French!


that was somehow turning off my x I think.

Great, I’m glad you’re back up again…

Good luck

:smile_cat:

Just curious what your line settings are?

I run,
250mm/s
22 power
0.04 line interval

This setup for me makes the outline’s pretty smooth.

@jkwilborn has that rotary I believe. He might have some input too.

Yes, I do have this rotary. It’s setup very nice and works very well in exchange for $$…

For coated mugs/compound lens, I run 300mm/s @ 13% and a line interval of 0.08mm.


With the other lenses I need to change the line interval to match what I can do with that lens… One of the reasons I have my materials library highest level being the lens…

I can’t get much below about 0.1mm dot size with most lenses and the longer one seems to be the worst…

Unless for a specific purpose, not much point of a tool size of 0.1mm and a dpi of 0.05mm …

Like having a 1 inch milling tool and incrementing it’s movement by 1/4 inch… you are wasting 3/4 of the operation and the tool isn’t working like it’s designed… ‘lasing’ is still a ‘machining’ operation… speeds/feeds are critical…


My machine was ‘sold’ as a 50W ‘China Blue’ … it measures 44W with a Mahoney power meter… it’s also 880mm in length equated to about this power.


@aatafoya I have multiple .lbset (machine settings) files for different operations. I typical slow the Y axes acceleration and speeds down pretty low, sometimes in the single digits. Vector graphics are probably the most difficult…

Good luck

:smile_cat:

Mph 200
Pwr 25
Height 7mm

Keep in mind that was my starting point and it worked so I kept it at that. I didn’t do any trial tests. I’ll have to go back and try it again with a cup that I don’t care about.