Piburn Rotary Tool - first step in Lightburn Settings

Hi Guys,

I’m installing a Piburn 2.0 on an Endurance Custom Diode Laser.
Looks like I got some issue with the Origin settings.
Here is the way I installed the Piburn on my 450x750mm device.

In the “Rotary Setup” Menu, I have put those values :
setup_21cm

At the first start, the LaserHead was homing good on X, and I had to home manualy on Y.
It looks good.
I try to move 1cm on X ( starting from origin) , the laserhead starts jackhammering.
But I have find out that in a particular area , it was working fine .
This green zone in lightburn.

.

As you can see , I can move the head on the 750mm of the Y axis, and move 21cm on the X axis.
But I can do that starting 2cm right of the X edge origin.
I thought that was like a margin.
In Piburn documentation it says : “Disregard “Object Diameter” and “Circumference” values, they do not affect anything”. So I tought that can put 450mm, to comply with my 450x750 device.
When I have changed the settings , and tried to move at the origin of the greenzone, it jackhammered.
So I reboot (device + lightburn).
It still jackhammered,

I came back to 210 mm in the 3rd parameter and then noticed that the X origin begins 4cm more on the right (meaning 6cm from the real origin).
I still have 21cm of width where every move are working fine.

X origin is shifting.
After several restarts, the X Origin is now 440cm far from the real one .
Y got no issue.

So what do you think ?
Where i’m wrong ?

regards

Without digging into the rest of your post, you have the rotary oriented incorrectly for the Lightburn rotary setup. You have selected Y axis for your rotary axis, but the rotary is oriented so X is the rotary axis.

Thanks TomWS,

just to confirm, you mean choosing X axis in the setup of Lightburn ?
Or changing also the wire from Y stepper motor controler to X ?

regards

What I mean is that the setting in LightBurn rotator setup pertains to the hardware axis that actually rotates the material. One axis rotates, one axis operates linearly so, when you have an object to engrave, Lightburn know which one to drive as it draws the engraving.

Unfortunately, Lightburn Rotator code doesn’t support using the X axis as the axis that rotates the material. So, your choices are: Y axis, Z axis, or A axis driver. I don’t know anything about your laser other than it’s a very safe bet that it has, at least, one X axis and one Y axis. Since you can’t use the X axis hardware to rotate, that leaves you with the Y axis (or one of the others if your hardware supports it).

The way you have your PiBurn positioned, you can not use the Y axis to rotate (the Y axis positions along the length of the object being engraved). And we KNOW (from above), that you can’t use the X axis, so either you’ve got some other axis drivers you can use OR you must reposition your rotator so Y rotates the material, while X positions the beam along the object’s axis.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.