Pop up says-The system time is incorrect or has been tampered with:

I just download Lightburn and tried to enter my key, but I get the message shown above does anyone know what the deal is? I have adjusted my time and the world clock to the time here in Phoenix AZ and I still get the same popup. Has anyone had this happen to them or can offer advice? thank you

Did you download Lightburn from the Lightburn site?

Almost sounds like a hacked copy…

@JohnJohn might be able to clarify what’s happening.


It’s likely that your PC simply has come out of sync with the atomic standard time.


Follow the guidance in the reply there - it will likely fix the issue

Thanks for coming to the rescue… :wink:


yes, straight from Lightburn. I just did it this morning. I’m on another laptop now, seeing if that was the issue. Thank you

Thank you Colin, I tried all of the suggestions listed, and still nothing, I’m now trying a different laptop.

Thanks everyone. I was able to open Lightburn on the other laptop I have. The other laptop must be a bad one.

This topic was automatically closed after 30 days. New replies are no longer allowed.