Portable 5-Watt Diode Galvo Laser - Z3 model

I searched and found exactly 1 post about the Sainsmart Genmitsu Jinsako Z3 - which is made by the company Donguan Xinjia Laser Tech. Co as their Z3 model and sold by several companies as that brands name Z3 portable 5-watt galvo laser. Like the Jinsoku and the Wainslux Z3. I’m curious if anyone has gotten their Z3 to work with Lightburn. Here’s why:

So, I received my Jinsoku Z3 and tried to use their LASER_BLE software, and it makes me want to punch a priest (I, of course, would NEVER punch a priest - it’s simply a saying denoting the lengths a person might go to to avoid ever having to do something again, even something that might be considered morally bankrupt or send one straight to the netherworld). This LASER_BLE software is SO VERY VERY BAD that it has led me to bouts of turrets-like cussing, punching, and screaming (I have nothing against anyone suffering from this debilitating disease, and I feel your pain - it was simply a relatable example). I’ve tried it via Android, and if I can get it to even connect after multiple attempts, it is so painfully slow, and crashes most times that it’s simply unusable. So, I set it up on Windows, and it’s slightly better, but not by much. It is SO poorly coded that, for example, if you don’t have the very tip of the cursor physically on a part of a letter of a folder or file name as you attempt to choose a file from your own machine that it won’t recognize the mouse click. At all. And even then it’s finnicky about WHERE on a letter it is. Not to mention how insanely poorly it imports an image file into the app. Even a high-rez SVG file will import AND etch like something pixelated and straight out of Minecraft. It’s an INSANELY bad software. If I didn’t already shave my head, I’d be bald by now just from trying to use it.

So, I installed LaserGRBL and tried it. LaserGRBL sees it on the correct port and correct communication speed, but times out before the laser gets set up. And then I tried Lightburn. I’d have started with Lightburn, because, well, it’s the best. But everything I could find said it wasn’t compatible. Still, being told NO has never stopped me before. So I let Lightburn find my device. The first time it crashed Lightburn, but that might have been my fault for not rebooting after uninstalling a deeply invasive antivirus software. After rebooting and trying Lightburn again, it DID find the Z3. Found the right port, the right communication speed, and even pulled in the correct laser line thickness. But I couldn’t get Lightburn to control the machine, and when I tried to open the Machine Settings it would time out and give me nothing.

This is interesting to me that Lightburn even saw the laser, because everything I read said it wouldn’t. It’s almost as if once upon a time they TRIED to make it Lightburn compatible but gave up.

But here’s the thing - the same manufacturer makes the Z5-1 and Z5-1Pro, both with currently empty software and documentation downloads of the date 2/24 ( https://www.dkjxz.com/ ) - which I’m betting is the exact same machine as the new Longer Nano and Nano Pro portable 6- and 12-watts (respectively) that Longer is finishing their Kickstarter campaign for ( https://www.kickstarter.com/projects/longer3d/longer-nano-6w-and-12w-affordable-and-portable-laser-engraver ). And oddly, BOTH these models are apparently Lightburn AND LaserGRBL compatible. Which begs the question, how? I know it’s coding related, but people have gotten random lasers to work in Lightburn simply by mucking around with different coding parameters within Lightburn. So, I ask again if anyone has gotten a Z3 model of portable laser to work in Lightburn?

And, before you ask why I got the Z3 instead of waiting for the Longer Nano, two reasons: I needed it right now, AND, I hit a sale and got the Z3 for the same price as the Nano once you include the Nano’s $55 S&H cost. When the software works, the Z3 works fine, but the only images that don’t come out looking like crap are those that come preinstalled with the LASER_BLE software, which has made the Z3 almost useless since those aren’t the images I want to use.

If there are any geniuses among you who might have figured this out, I’m all ears! Err, eyes… :smiley:

Is my understanding this machine offers ONLY control by their little app. The fact that you were able to get it to talk with lasergrbl at all seems to be a huge progress

In lasergrbl if you type $$ in console and $i
what output comes?

Also, are you able - to connect to lightburn using a standard GRBL controller profile?
I am assuming it connects via serial port usb right?

Both LaserGRBL AND Lightburn find it. LaserGRBL gives a timeout popup after 10 seconds of seeing it however, which makes it so I can’t talk to it. Lightburn found it and set it up as a GRBL device automagically, but after that it’s incommunicado - I can’t open the Machine settings before it times out, and thus, I can’t enter coding there, either.

And yes, USB connection using the CH340 driver.

it might not be a standard GRBL, maybe you would need to get a serial port monitor software to try to “see” what its saying when connecting

sounds like a “reverse engineer” task

I was kinda hoping somebody had ALREADY reverse engineered it! :slight_smile: But okay. I’m game, I guess. Maybe I’ll figure out how to get the Nano, too, and that’ll give me a clue once I look at IT’S machine settings…

Still possible that to be the case.

Got to give the mind hive some time to engage! lol

However, if is modified GRBL it might just be that GRBL/LIghtburn send a command and the machine never responds. Therefore, they assume connection fail.

When I try to use LaserGRBL while monitoring, it says it’s access was denied. When I try to use the LASER_BLE while monitoring, it never connects and the status changes to PENDING in the monitoring software. Lightburn also denied access to port while monitoring.

So, I stop monitoring, and open Lightburn. Console says “Waiting for connection”. Turn on ALL and get G0 endlessly. I go to EDIT the device and it sees it again, as a GRBL 1.1 or earlier device. I change communications rates and get nothing in return, still Waiting. So Lightburn sees SOMETHING, but not enough to communicate past that.

This is normal. Serial ports are singular only one device can connect to them.

Let me ping @LightBurn Oz maybe he has some idea on how to look at it better.
@JohnJohn Might tell us if this device (or twins of it) are in the database already and theres a solution.

Seems clear is a serial com, but unclear what protocol. might be fully proprietary.

Controllers are like people…

You can meet in person, but with no common language, you can’t communicate.

The manufacture doesn’t have to do much to ensure it won’t talk any other software but theirs.

With the low cost of controllers, unless it’s for academia type research, it generally isn’t worth the time you have invest to get it working.

These little machines are pretty cleaver and I’ve been watching them. They come up with pretty neat stuff, but the construction is typical Chinese… same box different vendor label on the cover.

I’ve never had one, and I doubt I will because of cost… it would be interesting to know how the galvos are controlled… wonder if they could contain the same basic operations we’re used to with just a vanilla grbl and motor drivers.

Know what you’re buying.

The Z5, in the advertisement calls this machine a fiber laser… it isn’t. I’ve seen the inside, they are not large enough to hold the fiber (the amplification part of the laser). The one I saw inside of, had no fiber in it at all and was determined by the investigator to be a yag laser. Unfortunately, that youtube video has become private, :poop:

It operates at 1064nM beam frequency as does a fiber, that’s the only relationship. Most of these are lucky to get out 2W…

Might have to bite the bullet and enjoy their software…

Good luck


I don’t have any info on this device.

Wireshark is the serial communication tool of choice if we’re tinkering.

I’m certain I saw this video as well.

So, I came at the machine from every direction trying to find a way around whatever blocks were in place to get the machine recognized in Lightburn, but just couldn’t find one. So, I tried the software again to see if I’d missed something, only to discover it is SO much worse than I had originally gleaned

Neither the Android or the Windows version could be used without it crashing. The Windows version would just seemingly randomly lose connection to the laser, even after trying different USB cabling. Then I found it wasn’t as random as I thought and could recreate the disconnects and crashes every time. I could never get it to a point where it would actually get through to the point you could start lasering. Mind you, I had just nuked and reinstalled the OS on this laptop and had only installed LASER_BLE when coming across these issues, being sure to disable all unnecessary services as well, to try and eliminate anything running in the background. I suppose it could be hardware, but unlikely.

The Android version was even worse. There’s a “Help” menu in the Android app, but when you open it up there are 3 “Videos” for training, except there AREN’T any videos at all. Nothing is there. Also, if you try to open any image, even the ones provided in the app, the app crashes and you get a message that the apps cache is full - on a Samsung phone with 12GB memory. I even rebooted, used my Droid Optimizer app to stop everything running in the background, and tried the LASER_BLE app again, and again, trying to open any image crashes the app with the same error. So, whomever wrote the program had no idea how to automate cache cleaning, or didn’t care.

While I was doing all this I received an email from the manufacturer to rate the laser. So I did. It was a very bad rating - not about the actual laser, as I was never actually able to use it because of the software, but I made sure to make sure people know just how terrible the apps are. This got a response from the company, who verified that it has been coded to be proprietary to the LASER_BLE software only. I have no use for bad hardware OR software, so back it went. They were kind enough to send a prepaid label, so that’s nice.

And since I already missed the need for the laser, once I get the refund I’m going to try the Longer version which apparently WILL work with Lightburn. It will simply make for an easy way for personalization - like names or phrases - to existing projects or products when hitting certain festivals.

Anyway, thanks for the feedback and involvement. It’s too bad there’s not an easy way to download the firmware off the machine then rewrite it to work with the industry standard softwares. Maybe there is, but I’m not the man for that project. I truly LOATHE coding. I can code if given enough time, but I’ll hate every minute of it, and there are far better people out there to do things fast and correctly and, above all, who’d enjoy every minute of it. They are clearly ill. But God bless them! :smiley:

Thanks again, all!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.