Positioning Laser Head Grbl

Every time I home my Grbl device, my laser head needs to be repositioned to the correct distance to my cutting target (Since in my case the laser moves up until limit switch). Is there a way that my selected position gets stored and I don’t need to configure it every time I home?

I see no way to store this configuration so that when my operation starts the laser head moves towards the correct position automatically.

You can set a macro for the homing. I have one that homes my xy and z, and then sets the z to the correct height for a typical 1/8" sheet of acrylic. For thicker Items I adjust the z with the buttons on the move tab.

That’s a great idea. By any chance you have an example code I can use?

Why not just use “Absolute Coords”? This way, wherever you have the design positioned in the workspace in LightBurn is exactly where it will go when cut.

1 Like

This is for the z axis. Light burn doesn’t have information for this axis. When I home my laser it moves up. The laser needs to get positioned down every time I home to have the laser properly pointed. This is very important for someone that has a motor to position the laser in the z axis. A macro that homes and applies the positionning looks to be my only way out. Hope in the future this is better integrated in the software.

I think I got it. I mixed the two sugestions:

I am using this script to position the laser:

G10 L2 P1 X-770 Y-290 Z-100
G0 X0 Y0 Z0

It would be nice on the home button from Lightburn to program the macro.

Thanks for the help :slight_smile:

You could try entering the material height value in the “Material (mm)” value in LightBurn. If you don’t have “Relative Z moves” enabled, all moves are relative to that height value.

I am currently using the following options: Z offset, z step per pass and relative moves enabled. I noticed that there is a material thickness value on material library. What does this do to my current configuration?
If set my target z height at the origin, what is the difference between relative moves on and off? 3. What is the material thickness doing simultaneously to this configuration.

For now i think the process should be something like this:
Define a origin for z
Disable relative moves
On material thickness in material library define value to focus the laser to the material thickness (5mm relative to origin).
Activate z step per pass.

What I am expecting: Laser head moves to origin (down 100mm) -> on working job the laser head moves up 5mm to specified height (material thickness in material library) -> after a pass the laser head will move down 0.3mm (for example)

If you have “relative Z moves only” enabled, it just issues relative mode Z commands for the steps and Z offset moves, so LightBurn doesn’t need to know which height it started at.

With the “relative” button off, the starting height of the cut is the “Material (mm)” value. LightBurn will position the head over the job, issue a G0 Z move to the material height, and cuts will happen relative to that.

Note that the Material height setting is global, not per cut layer.

So Lightburn will move to a point distant from origin z mm. That’s perfect. I think I finally got it. No more setting manually the distance every time I use the machine with same material. Thanks!!

1 Like