Possible cure for laser not working

Hi all.
This is my first post.
I bought a cheap laser head for a project, and then saw an ad for the Eleksmaker a3 pro at a good price (without the laser unit) so bought it.

Problem was when i tried to use it there was no output at all from the laser.
After trying everything i could think of software wise, i had a look at the hardware.
I downloaded a good layout of the control board and looked at the pins on the board.
From left to right they were PWR +, GRD- and PWM, or Red, Black, Yellow, but the wires in the laser plug were Yellow, Black, Red.
I used a small screwdriver to push the red and yellow connectors out of the laser plug and changed them round. The laser worked fine after i plugged it back in.

I hope this helps someone who is having problems.

This is a classic issue with some lasers.

When buying laser diodes from china they often come with instructions which say check the own wires are correctly orientated and change if not.

If that is a part of the user manual, it should be a substantial indication to consider another manufacturer. :fire_extinguisher:


The lasers can be added to a whole host of machines… 3018’s, orturs, homemade etc… They may have all different wire/pin orders so it makes sense to put it in the instructions.

Plus, the K40’s are deathtraps from my reading… Not grounded, extractor pipes which fall apart etc.

The problem was that my head unit just came in a bag without any documentation. This may be the case for many who have bought a separate head,