Precise homing issue after running a job only works ok if i hit home

hi all
i have a new sculpfun s30 pro with extended bed(previously had large co2)
i am pretty familiar with lightburn nd been using it for several years in my business
however i am having a issue with homing. what i mean by that is this.
if i jog the x y axis and then home, it homes exactly to the limit of the microswitches as expected . It then stands off by 2mm thats fine
HOWEVER if i run a job and then have it eneble for home when finish ,it does not make contact fully with the Y microswitch? it stops short by around 2mm? and i have to then manually home (every time) to make sure it starts from exact home position, otherwise it does not know it is starting from home!
I have also tried in the machine settings to remove the 2mm stand off and i set it to zero, to see if that’s the problem but it makes no difference
any fix appreciated
I have changed the Y axis Travel also to compensate for the larger 950 bed.

It should return to home position after job completion. However, it should not actually rehome after the job. Meaning, it should not touch the switches after job completion. Ironically, depending on the repeatability of the homing procedure, homing could result in slightly different actual start positions within the tolerances of the homing procedure.

Can you elaborate on this? If you were to run the same job twice in a row without rehoming the laser should be able to trace the exact path twice. Is it doing this?

thanks for reply berainb much appreieated

ok i am confused a bit? you say it should rehome after job completion
and then say it should not actually rehome after the job? i am not sure that makes much sense

i agree after job completion it should rehome , that’s how i have always experienced it, but my machine is stopping short , and by not confirming it has rehomed it will not run the job (for a second pass for instance) in exactly the same position
surly if you set it to rehome after job completion enabled, it should find the home position( x and y limit switches)

I’m distinguishing between the home position vs running a homing cycle. It should return to 0,0 position or whatever arbitrary coordinates you’ve specified but not running a homing cycle which includes engaging the homing switches.

Does it return to the final resting position following a homing cycle? Or is it 2mm off from even that?

Something is not right if that’s the case. Something is causing your machine to lose position. This could be caused by uneven tension in belts, overtightened wheels, or something similar. It could also be if your laser is not on a level surface. If this can’t be easily remedied you could configure the stepper motors to always be energized which will prevent any unintended drift.

For confirmation, are you doing this with the “Return to Finish Position” option in Edit->Device Settings? Or is this something else?

“Return to Finish Position”

yes i have that set berain
Does it return to the final resting position following a homing cycle? Or is it 2mm off from even that

nope its fine if i actually say home it touches limit switches and 1then sets a 2mm off set
it is just after a completed job it does not fully home( engage limit switches)
ill give the steppers a try as you suggest
thanks very much for assistance
its not a big deal as long as i remember to reset (home ) before i run jobs
belts are good no free play and tight

The position after that homing operation is defined to be the “home position”. Setting Return to Finish Position will return to that spot.

A simple test for that is to fire a pulse into the surface after the initial homing operation, then again after the job.

If those two burns do not hit exactly the same spot, then, as @berainlb says, the controller has lost track of its location, which is typically due to motor stalls or mechanical backlash.

What that means: somewhere during the job, the laser will be cutting or engraving where it should not. The error may be small now, but it will come back to wreck the only piece of a really expensive material when you least expect it.

I think I’m not making myself sufficiently clear on this. It should not, as in it ought not and will not engage the switches as-if it were going through a homing cycle.

It should only reposition the laser to go to the location specified in “Return to Finish Position”. This is typically 0,0 which is being loosely referenced as “home position”. It should not execute a “homing operation”.

I’d suggest not relying on this to prevent unwanted movement. If your laser cannot maintain accurate position without keeping the steppers engaged there’s something else going on that you want to address first, else you’re only masking the root cause.

Tight by itself may not be sufficient. Overtension or other improper tension can cause this. Basically you’re looking for anything that would generate a residual spring force that is shifting the laser after the steppers stop holding.

Note that @ednisley is describing a potentially different scenario resulting in a similar outcome.

I’m describing a scenario where the controller is tracking all steps but the machine moves post rest.

Ednisley is describing a broader scenario where motion is unaccounted for.

If the laser head moves immediately to a physical location after the job is complete that does not match the original 0,0 position then ednisley’s suggestion is likely correct. You’ve lost steps somewhere along the way of the job.

If the machine slightly drifts after stepper motors are disengaged then what I’m describing is the likely culprit.

I don’t know if I got everything correctly now, but here is another remark:
The homing function in grbl offers some compensation for switches that usually have some hysteresis (different activation and deactivation positions). That’s called “homing pull-off”, controlled by parameter $27. This is usually set to 1mm, I think at the S30 firmware it’s 3mm by default. This means, after a homing cycle, the laser is moved that distance back into the workspace to make sure the switches are released properly. Because if you hit them again they might trigger a hard limit alert which stops the firmware. Now, the different firmware versions behave a little different. Some versions set the position to 0,0 AFTER the pull-off, some BEFORE. So depending on that, you might have 0,0 as position after homing or 1,1 or 3,3 (depending on $27 setting). I think I had some cases where this behavior also created some repositioning error (though in theory this should not make a difference in absolute coordinates).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.