Preview button not working


(Sebastian) #1

Hello guys,
my first laser is on its way an I´m looking for a good software which supports OSX and the german language. So i found Light Burn, downloaded the trial version and did some presale testing.

I like the software a lot but have one simple question:
When i click on the preview button nothing happens… is this a bug, wrong setting or is it just because no laser is connected ?

Thank you!


(Rick James) #2

I have a Mac running OSX 10.13.6 (17G7024) and I have never seen this before. Once you click the ‘Preview’ are you able to then do anything else within LightBurn? Please try and provide details about your setup and step-by-step instructions so we can try to recreate.

Does the same happen if you pick ‘Preview’ from the ‘Tools’ menu or press the Alt + P keys?


(Sebastian) #3

Hello Rick,

I´m running it on OSX 10.14.5 (18F132 - Mojave).

Let´s say I´m drawing a simple square and then click on the preview icon in the top toolbar (just like in some simple light burn tutorials on youtube) then just nothing happens. It´s not like something is crashing, it´s just not working.

Alt + P is also not working and under tools the same.

I just thought it´s maybe because no laser is connected or set up.


(Sebastian) #4

Here I made a simple Video - let me say again that there is no Laser set up or connected.


(Rick James) #5

Thank you for reporting this. As mentioned, never seen this before so I will generate a bug report. I test all the time without a connection on multiple systems and laser configurations, so this should not be an issue.


(Sebastian) #6

Ah okay - thank you!
I hope that there will be an update available soon - didn´t find a better Software with german language :slight_smile:


(Rick James) #7

Can you please try something for me, change the language to English and try again. Does the Preview work now?

Here is what I see.


(Sebastian) #8

Tried it with no luck.

  • Opened Light Burn
  • Changed language to english
  • Closed Light Burn again
  • Restarted Light Burn with english language (like set before)
  • Drawed a square like im my video above
  • No preview

It´s like a popup blocker or a dead button


(Rick James) #9

Report generated.


(Sebastian) #10

Okay - is there a way to check the report status ? So i can take a look when it´s solved ?


(Rick James) #11

We will respond to you here with an update/resolution when available. Our bug reporting system is not accessible to the general public, sorry.


(Sebastian) #12

Okay thats good for me =)
Thanks!


(Rick James) #13

I may have misspoke. Do you have any ‘Device’ defined at all? LightBurn needs at least one single device defined and selected (you do not needed it to be “connected”) to know what features are supported and should be displayed.

We are talking internally about displaying an error message if this occurs to provide clarity and the appropriate solution.


(Sebastian) #14

That´s what I meant with not connected and nothing set up.
Just added a Device manually.

Now I can see the preview! So no bug!

But a popup would be nice with a warning that you should add one device at least to get all functions or the device provided functions.

Thank you for your advice !


(Rick James) #15

Glad you got it sorted.


(Sebastian) #16

Great community!

I like the Software a lot and will buy it this week, its easier to work with a software which has a strong community behind its back.

Just one thing to improve - a lot strings are not translated, not a problem for me but maybe for some other people. Thats all =)


(Oz) #17

Translation is tough - every time I alter or add text, it needs to go through the translation process again, and things change relatively quickly. I’ll be releasing another language pack for the translators soon.


(Sebastian) #18

Hey Oz, okay sounds great!

I don`t know how your translations process looks like but if you need some people to convert some strings to german let me know.


(system) closed #19

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.