Preview Error msgs re 3 Unclosed Grid sections making No grid lines at all

Here’s Preview of my attempted Grid–but no lines at all, though other New LB’s showed Differently–2 or 3 with some lines showing.

Here’s what all the Previews had, being fully selected (^a).
What it’s supposed to be from Online Purchase for Sculpfun S30 Pro Max Lg Extension:

The cut layers just appeared when Grid ai imported, the fill layer seems to be filling a pair of lines maybe–and wants the parallel lines to be closed. Dunno. i’m a newbie.

 Another error in Preview say what i know on CNC as Out of Bounds.  But the Preview shows all 890mm in both directions.


Here’s another rendition of Preview re Unsent lines/fills:
Import 3--Play 4 Line FINAL No Horizontals (like imprt 1

The grid was done in another tool? It looks like the shapes weren’t exported properly. Additionally, it seems that it is bigger than the workspace (and you should not resize to make it scaled correctly).

I recommend doing the grid in LightBurn yourself, it’s just a matter of minutes. You can draw a line and then use the grid-array tool to repeat the lines as desired. The same for circles, you can use the offset tool to create the bigger circles.

Maybe post your file here, then it’s easier to check for errors.

Thanks, Melvin, Some of issues with my previews is my ignorance. i think i need to preview (and engrave??) Layers one at a time, or that don’t cross each other. (??). At any rate my attempts and making the one layer/selection’s perimeter of 890 sqare still fails to satisfy–even though i edit my workspace size to 895, & then 900. I can see the faint lines of the LB work-grid showing on top & to the right of my 890mm project, which i’ve made sure has x & Y showing 0.00 & 890 up in width & height. Always get the Preview warning and removal of entire perimeter. … Were you suggesting i upload the import ai image here? i could make it PDF or svg?, according to best way–if you were wanting to check it out. It does appear to be solid when i separate its parts.

Because you are using fill mode and enabled overscan, I guess. The laser then will travel some distance extra to incorporate for acceleration / deceleration.
Change this to line mode. For a grid, this is better anyway. Will be much faster.

SVG would be the best option, I think.

Melvin, Making more divisions & layers to simplify diagnoses. Preview showed missing horizontals in upper right, so i isolated them on new layer but they seem to erase. Search told me that there would be ‘alterations’ if the selection comes from a group. If deleted, that’s a very strong alteration.

Here are the culprits:

My LB project with enlarged space to 900 sqr.

GRID 890mm Sqr on Base Board - DeLLL2.lbrn2 (731.3 KB)

Original at 890
GRID 890mm Sqr on Waste bd Converted

Pretty surprising that LB would ignore the settings & even Stop sending data to make the settings work.

What exactly do you mean by this?

Here is what I meant, you have the text set to fill and use overscan. This means that the laser will travel further than the project size. If the grid is precisely the size of your workspace, it won’t fit because the travel area is missing. In such a case LightBurn won’t start the project (depending on settings). See the red lines here:

In general, try to avoid any fill layers. Everything should be done using lines. This dramatically speeds up engraving. I’d recommend using a single line font (SHX fonts), that is much faster.
Additionally, you have set the fill layer to “fill all at once”, which is making things worse, try “fill shapes individually” to speed up engraving (check how the preview changes).

Yes, i uxnderstood you. I don’t understand why when i increased the basic expected machine sizes to 900, it still was called Out of Bounds.

(Filling text for me makes it larger, darker, & more readable for my eyes, but this particular arrangement for a grid is maybe the pnly project & text right to the edge, i’ll have.)

Thanks for the clarity. With fill text leaning over the ;890 line, I do need to know why 900 square for workspace size setting still doesn’t fly. That’s the working space for the Sculpfun large extension, yes?.

PS, Melvin. i changed the fill to line, saved the file, and get the same msg.

The Preview result contained the perimeter line and all the numbers on the right as before, But again the very upper horizontal lines above the center square don’t come through. They don’t extend past the 890 square which does show,
This is with all the Output & Show turned on to green.

Where does the 900mm square come into play?

If every thing shows, including the numbers in the msg in Preview, does the msg matter? Is it just warning and sends to the laser anyway?

Where exactly did you change the settings? I guess the LightBurn message is based on the workspace setting in device settings. If the laser gives a message about machine bounds, it’s the $130 and $131 firmware setting. In general, both should match. Since every setup is a little different, I highly recommend measuring your workspace size yourself.

  • home the laser
  • jog the laser using the arrow buttons as far to the end of each axis until it hits.
  • the last successful move without a hit was the maximum workspace size
    (use large steps in the beginning and finally end with mm-movements)

After you got those true values, enter them in both machine settings (firmware) and device settings (LightBurn).
Then you can also adjust your grid template to fit into this size. Here are some expected sizes (but not true to the last mm).


Do you mean the upmost lines are not sent and also not visible in the preview? Then it might be because you are in absolute coordinate mode and the lines are above the actual workspace? Then LightBurn won’t send them. Or did I get that wrong?

Not really. If you are sure the laser can reach all area (do a frame), then you can send it anyway and check what is happening. Stay close to it and stop it if it hits a frame at some point.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.