Preview not showing up in new version

After upgrading to the new version, the Preview window is not working. Check out the Total Time Estimated: numbers

That means there’s something in the design that’s confusing the simulator. Can you post the file here so I can figure out what’s happening?

I will post the file, but it is the same with other files that were working fine in the previous version.

I got a message that says “Sorry, new users can not upload attachments.”

Here is a link to the file in DB.

You have perforation mode enabled in the first layer (the text). Which version of LightBurn are you running? Mine doesn’t fail, but it looks funny because of the perforations:

image

The newest version, 9.
The preview does not work with any of my files. It worked fine before the new update.
The perfs were just on oversight.
Did you open it in the newest version?
Should I re install it?

“9” is not a version, but 0.9.06 is (you can see which one you have by going to Help > Quick Help and Notes, then the About tab). I did open it on the latest version, yes.

Do you have a device selected (as in, a machine profile set up)?

0.9.06 is the version i am running.
In a different file, If I disable output for the fill layer or change it to a line, then preview works.
If I enable the fill layer it does not work.
Try my file again with the text layer as fill instead of line.

Yes the device is selected

Which type of controller? (this might be relevant)

The Cohesion3D smoothieware

This is very odd - I can’t get it to fail. I’m going to go try on my Mac to see if that behaves differently.

so with a little experimentation this is what I found.

I opened the Power Scale file on my laptop with v0.9.04 and it worked fine.
I upgraded to v0.9.06 on my laptop, opened the file and IT WORKED fine again.
both computers are Macs. They are both running High Sierra.
I will reboot the iMac which the laser is connected to and see if that helps.
Thank you for your involvement in this.

Rebooted the iMac. I still have the same problem.
If any layer is a Fill the preview is wack.
If all layers are Lines the preview works fine, just can’t see the scan/fill procedure.

This is v0.9.04

This is on iMac with v0.9.06 all layers as lines.

Pretty sure I’ve figured out what this is. Go to your device settings and either turn this off, or give it a speed other than zero:

image

I’ve also fixed the bug itself, and it will be in the next release.

1 Like

Thank you Oz, that was it.

It is back to functioning within normal parameters.

Thank you for your diligence.

I like this software. I am new to laser and after a lot of research I landed on you guys because you seem to have the best solution for Mac. (almost the only solution for Mac).

Still learning and testing and figuring this all out, but I am excited to start creating and producing.

I was going to post last night to tell you thank you but I had reached my posting limit for a noobee.

Thank you for your help in getting this sorted. I have bumped your status up so you should not have posting limit anymore. :wink:

You’re welcome - It’s hard sometimes striking a balance between offering the control that some people want, and limiting the ways in which you can shoot yourself in the foot if you’re new to things or click something accidentally, but every time someone reports an issue it improves a little, so thank you. :slight_smile: