Preview "Play" speed not the same as actual cutting speed

The actual cutting speed of the laser is much faster than is shown in the Preview “Play” mode. I’ve made a simple 10 mm horizontal line and set the cutting speed to 10mm/min. When I “play” this in the Preview Window it takes the expected 60 seconds to cut (Playback Speed = 1.0X). However, when I go to actually cut this line, it only takes 13.5 seconds to finish. That’s about 4.5 times faster. I can’t figure out how to get the play speed and the actual speed to match. Can anyone help with this one? Thanks!


Take a look at the ‘Additional Settings’ tab of the ‘Device Settings’ window. These settings control the ‘Cut Simulator’. Change these settings to match the settings you have in your firmware if using a GCode system OR the settings saved in the controller itself if using a DSP type controller. (I see you have an X-Carve so for your setup, you want the numbers saved in your firmware.)

You can view ‘Edit’→’Machine Settings’ to see what is currently set on your system. Use those numbers to tune the simulation to better reflect actual job processing time.

Dialing these numbers to match that of your hardware will produce a more accurate play-back estimation displayed in LightBurn.

I think the problem might be the other way around - a 10mm line, running at 10mm/min, should take exactly 1 minute to finish, as he said. If it’s taking 13 seconds, it seems that the controller is ignoring the speed setting and going faster for some reason. Check the GCode to make sure the feed rate is being set correctly, but if it is, it’s on the controller side.

Hi, Rick,
Thanks for the reply. I could only change the speed and acceleration values since the others (e.g. engrave acceleration, rapid speed, etc.) weren’t present in my GRBL’s settings (version 1.1g). I made the changes so the Lightburn values were the same as those found in my GRBL’s settings, but the changes made no difference in the speed differences between the simulation and the real cut. The simulation’s timing is correct. What’s happening is that the X-Carve moves way faster. Can you suggest other possible solutions? Thanks!


Other than the suggestion from Oz,

maybe reach out to the good folks at X-Carve for their input on the controller side of things. Have you had a chance to review the GCode for feed rate settings?

You shouldn’t change the controller settings to match LightBurn, but go the other way - The LightBurn simulation settings are sort of a middle-of-the-road for a dedicated laser system, but would likely be too fast for a CNC with a diode mounted on it. The intention is to let you tune those settings to match your machine.

Right…that’s what I did. I found the “Max Speed” and “Acceleration” values in my firmware settings and changed the values in the “Additional Settings” dialog box in Lightburn. However, doing so didn’t solve the problem. I plan on saving the Gcode Lightburn creates and sending to my X-Carve via UGS, PicSender and Easel to see how it responds.

Sorry - I mis-read what you wrote. :slight_smile: For the engraving accel/speed you would just set those to match your global accel/speed values, since GRBL doesn’t differentiate the two. Lots of DSP controllers do, which is why they’re split.

You could do a very simple test from the console in LightBurn. Type these two lines:

G0 X50 Y50 (press enter)
G1 X60 Y50 F60 (press enter)

The first command moves to 50,50, and the second tells it to go to 60,50 (10mm away) at 60mm/min, or 1mm/sec. That should take exactly 10 seconds, plus a negligible amount to accelerate / decelerate on either end.

Wow! I must have really screwed up my firmware settings somehow. When I sent the first command you suggested in LIghtburn (after homing), the spindle shot rapidly to the upper-right of the X-Carve. I had to press the emergency stop button to keep it from ramming into the rails. The same thing happened when I sent that command via UGS. When I sent the commands using PicSender, it appeared that the spindle moved the requested 50mm right and up, but when I sent the command to move right 10mm, the spindle move right AND up and it took 78 seconds (1:18). My current GRBL settings in PicSender are pasted below. Maybe you can spot the error? Thanks for your help!

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00010010)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:00010010)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=1 (homing cycle, bool)
$23=3 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=255 (rpm max)
$31=0 (rpm min)
$32=1 (laser mode, bool)
$100=39.86 (x, step/mm)
$101=39.86 (y, step/mm)
$102=252.764 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Those aren’t your settings “in PicSender”, they’re the settings in the device itself.

It sounds like you don’t have the origin set to front-left, which would mean you’re in negative workspace mode. You can use the GCode commands I gave you if you negate the numbers on X & Y like this:

G0 X-50 Y-50

If you want to put the machine into positive workspace mode, you can read how to do that here:

Right…I got those device firmware settings while running PicSender. I went to my X-Carve, shutdown PicSender and re-started Lightburn. I homed the machine and tried the negative G0 values. Surprisingly, the machine went down and left grinding into the rails. I turned the X-Carve off and back on again and re-homed it and entered the original command (G0 X50 Y50) and it worked as expected. I ran the second command and it worked as you indicated (e.g. moved directly right taking 10 sec to make the move). This is something I’ve run into before. I must not understand how different programs interact with the X-Carve’s firmware. If I’ve used another program to control the X-Carve before running Lightburn, is there something I need to do in Lightburn to be sure it’s interacting with the machine’s firmware correctly?

LightBurn makes no changes to GRBL’s settings at all. I can’t say whether PicSender does or doesn’t, but it might set a workspace offset, which would cause problems in LightBurn.

This might help: Origin set, but can't delete it

Try running the $# command referenced in the above post and see if PicSender is offsetting your machine origin. That’s the only thing I could think of that would produce the result you’re seeing, and it wouldn’t be uncommon for CNC software to do that.

For what it’s worth, those same settings will be displayed by typing $$ in the LightBurn console and hitting enter, or by going to Edit > Machine Settings (with a nicer interface).

Yeah, when I type in the $# command I get this:

I suppose I had better create a macro with the following commands in it when I start Lightburn:

G10 L2 P1 X0 Y0

That depends on where the origin of the machine is. If the actual 0,0 location of the machine is rear-right, then you’d have negative workspace, and would need to use an offset to correct it. The Common Grbl Setups link above details this. If the machine origin is front-left then you’re correct - the X0 Y0 version would be what you want.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.