Preview seems to show grayscale not vector

Customer provided an AI file to cut and engrave. I picked the red layer 02 to engrave. When I preview it, it seems to be grayscale or have ramps. I did not set either. If I pick another layer/color [09] and make it fill, I do not get such a preview. There seem to be no settings different between the 2 layers.

Just tested another thing:

  1. Used my library for that color layer on the leather. Unlinked the layer from the library, changed the line to fill. No funky looking preview?!

Lightburn 1.2; LightBurn 1.2.00, built Thu 2022-06-30 @ 11:55. Mac OS 12,4.

It looks like you have a difference in you “Lines per Inch” settings between the 2 layers, also on the left image I believe you have a ramp set, this is under the “advanced” tab for the layer’s settings


I agree that the image looks as if there is a ramp set, and maybe 2 layers of different dpi- but no! I also discovered that after importing and having this happen, if I “Unlink” that layer setting from my library, removes the appearance in the preview. So my next question is why does this happen? Why does an imported object pick that library layer that does not have ramps, and apply that to the new, imported object.