Preview Tool's Invert Option

The Invert toggle button doesn’t appear to work unless you toggle the invert button off/on(?).

FYI. I prefer the black background in the preview window and tend to leave the Preview Tool’s Invert button set to on. However, when doing future previews, the invert option doesn’t work until I toggle it back off and then on.

If you’d like a quick video showing the potential issue, please let me know :slightly_smiling_face:.

LightBurn 0.9.16
Windows 10 Pro x64 (2004/19041.508)


The Invert option will automatically be enabled / disabled for you if your job contains a single image, based on the ‘Negative Image’ state of the layer for that image.

If your job is “generic” it remembers and uses the previous state, but it wasn’t setting it properly for the render window in that case. I’ve fixed this for the next release.

Thank you for the background on this feature and fix! I learned something new! :slightly_smiling_face:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.